PfSense image for Alix



  • Hi all,

    I want to install pFSense on Alix 2c3 motherboard. I will use a 4GB CF and I have found the following site:

    http://www.hacom.net//catalog/pub/pfsense/

    with different images of embedded pFSense available. The biggest image is of 1GB, so this should be good, I think, but I don't know which to choose among the ad0, ad2 and the da0 one.

    Many thanks for your replies.

    Cheers.



  • The embedded version of pfSense requires a card of at least 128 MB.
    Bigger cards work, but the additional space will not be used.

    I'm not sure what these different images are.
    Basically you can download physdiskwrite from http://m0n0.ch/wall and write the pfSense image onto the card.



  • The larger images have been resized so the partition is larger than 128MB. Not really that useful IMO- I don't think you are ever going to have a space problem with embedded. I don't know why they have those other images- my guess would be da0 is for running from a USB stick and ad2 would be if the card was a secondary master, maybe for a box (not an Alix) with both a CF slot and an ATA controller…
    Anyway, I would just use the stock embedded image from the pfSense site...



  • Hi and many thx for your answers,

    I tried the stock embedded 128MB image, with a 4GB CF, but I receive the following error:

    01F0 Master 044A CF 4GB                                 
    Phys C/H/S 7769/16/63 Log C/H/S 971/128/63
    No /boot/loader

    FreeBSD/i386 boot
    Default: 0:ad(0,a)/boot/kernel/kernel
    boot:
    No /boot/kernel/kernel

    FreeBSD/i386 boot
    Default: 0:ad(0,a)/boot/kernel/kernel
    boot:

    I wrote the image on a Linux box with the command:

    zcat pfSense-1.2-Embedded.img.gz | dd of=/dev/sdd bs=16k

    I tried to resize the stock image to fit into the 4GB CF, but I receive the same error of above.

    Just for testing, I wrote the Embcop 1.5 image for Alix into a 1GB CF, and booted the Alix without problems. I did not touch the Alix BIOS options.

    I would like to use a bigger CF so to keep as many logs as possible, am I wrong doing this?

    Thx again, cheers.



  • Same here.  The current 1.3 wouldn't boot for me with the same error.  1.2.1 RC1 loaded just fine.


Log in to reply