DNS Resolver and host override aliases



  • AFter updating to pfSense 2.3(.1?) I lost the ability to add/edit aliases for host overrides.
    I have a local server override with several aliases, and when I try to add a new one in 2.3.1 all aliases are lost.

    With a previous config (created on an earlier version) all aliases show up in the list and the resolver is handling them fine.

    Is this a bug?


  • LAYER 8 Global Moderator

    I have aliases, running 2.3.1 and just added another one to a host, still have the other aliases, looks fine.

    Sounds like you have some config corruption sort of issue if says works when you load old config.




  • Allright, thanks for replying.

    I'll take a closer look tonight, you might be right that about some config error.



  • Did you try try what I did in my post?

    Can you attach a image of what you want to add? But results in nothing upon saving?



  • I figured it out.

    I had an override for a specific host name, where the first alias was blank, aka the domain root.
    This worked with previous versions, but once upgraded to 2.3 this became a problem as the blank field probably where checked when looking for any aliases. Blank means none, everything deleted and so on.

    I switched the blank value and the specific host name, making the domain root the main override and the original host name an alias, and everything worked perfectly.


Log in to reply