Internet Access with 30 bit Mask



  • I have a Cisco SG300-28 layer 3 switch feeding pfsense.  It has been working for a while using a 24 bit mask.  I am having problems with Hulu streaming so I thought I would change things around.  I decided to switch to a 30 bit mask for the LAN side of pfsense.  I changed from command line on pfsense #2 interface IP and mask to 192.168.10.1 255.255.255.252.  I changed my layer 3 switch to 192.168.10.2 255.255.255.252.  I have no internet access from my layer 3 switch.  I can access pfsense admin console 192.168.10.1 from any work station on my layer 3 switch.  If I try to ping out from a workstation on my layer 3 switch I get the following
    C:\Users\lee>ping 8.8.8.8

    Pinging 8.8.8.8 with 32 bytes of data:
    Reply from 192.168.2.254: Destination net unreachable.
    Reply from 192.168.2.254: Destination net unreachable.
    Reply from 192.168.2.254: Destination net unreachable.
    Reply from 192.168.2.254: Destination net unreachable.

    Ping statistics for 8.8.8.8:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

    C:\Users\lee>

    I am thinking pfsense is blocking internet access and I need to change something but I don't know what.
    I have the networks setup under LAN routing for the layer 3 switch networks.  I have a gateway setup for the layer 3 switch networks.  Can you think of anything else?  It works with a 24 bit mask.  I can post screen shots of my pfsense config if this would help.

    My thinking is the layer 3 switch is working since I can access pfsense and configure it.

    To post this I have a workstation configured as 192.168.10.2 255.255.255.252. I have internet access with my workstation so this does not make sense to me.  I guess the workstation is in the same network as pfsense whereas when coming from the switch the workstation is in a foreign network not the same as a pfsense network.



  • The unreachable from 2.254 (I presume that's your L3 switch) suggests it doesn't have a default route, or doesn't have a correct default route. Its default route is unreachable or missing.



  • Never mine.  I miss typed my default gateway.  Sorry for the trouble.



  • I am still having the Hulu streaming problem where after a Hulu Ad not the beginning Ad but in the middle of a program the restart after an Ad it runs for a brief time them freezes then starts over right after the Ad.



  • Does that happen with all browsers?



  • I am sorry no browsers it happens with my Visio TV connected with wire a RJ45 connection.  I have loaded 2.3.1_1 and it still happens.  I had no problems with 2.2.6 so it is new with 2.3.  I can run packet captures if it would help?



  • @coxhaus:

    I can run packet captures if it would help?

    Yes that would be telling. Filter on the IP of the TV.