PPPoE not connecting with BT Infinity (UK)



  • Hi -

    I was wondering if you anyone could give me some tips.  I am a bit of a networking novice, so please be gentle and don't be surprised if I need more detailed explanations of things.

    I have a set up that has been working fine and suddenly stopped working at midnight last night.

    The device itself is an SG-2220, running 2.3.1 (upgraded about a week ago).  The WAN port is connected to the BT VSDL modem, the LAN Port to a TP-Link Smart Switch.  I am not going to go into too much detail about the LAN side as it's not the bit causing the issue (still have an issue when connecting the LAN port to a laptop).

    Last night at about 12:15am, my internet disconnected and I cannot get it to reconnect.
    At first I figured that there was a service outage on BT, and I was about to go to bed, so I went to bed thinking it will be up in a couple of hours (before I woke up).  I got up at 6am this morning, and still not connected.

    I power cycled the VSDL modem, and the SG-2220 to no avail.  Still no connection (I tried the 'connect' button in the interfaces section, multiple times last night, this morning before and after power cycling various components).

    I decided then to plug in the horrid BT HomeHub 3 router I had collecting dust into the VSDL modem (disconnecting the SG-2220), and it connected to the internet just fine.  It is because of this I am going to rule out a BT outage, or a problem south of the VSDL modem.

    I would rather like to avoid the doing a complete reset of the SG-2220 (kinda why I bought the thing in the first place, too many hours of my life were spent doing that before I went pfSense), so if there are any things worth trying I'd like to give them a go.

    Any advice that anyone could provide would be greatly appreciated.
    Apologies if this is in the wrong section - I couldn't find another that fit better.



  • Hello Fahim,

    Do your PPP logs give you any idea of the problem? can you post them here?

    Mike.