NUT help please



  • In a NUTshell…lol Nut is driving me NUTs.

    NUT won't start. I need help to either repair it or uninstall it and reinstall it. Details below. I am currently running 2.3.1-RELEASE-p1 (amd64). I'm not a *BSD or pfSense expert so please treat me like a child and go step by step and give details in your response. Also, NUT worked perfectly fine under 2.2.6 before things went bad and had to start fresh. NUT was setup to use an APC generic UPS to recognize my Cyberpower 850 and my Synology Diskstation 415+ was setup as the Network UPS server. Never any problems and it worked perfectly.

    This is a copy and paste from another thread I responded to but felt I should start my own.

    I had a corruption issue somehow and could not access the router via WEBGUI or console so I didn't get to upgrade or prepare properly like I had planned to. I was on 2.2.6 and decided today to just do a clean install of 2.3.1 then use the automatic restore method of a recent 2.2.6 config.xml file.

    NUT does not show as installed under packages. Under Services I'll get the 404 page. On the dashboard I have a yellow X circle and it cannot be restarted. If I try to install/reinstall it from PACKAGES, it goes fine and succeeds…BUT then my WEBGUI becomes unavailable and I can no longer access my router.  I have to reinstall and restore all over again.

    ***Update 1
    Last night as an experiment and a chance to learn, I installed/reverted back to v2.2.6 (what my config backup is based on) and NUT is still a mess. I checked the logs and it said the CONFIG file or file was missing. I don't know how to fix this. I'll probably post my own thread as I don't want to hijack this one and not sure if I can contribute or if our troubles are the same.

    I've searched this forum and I even tried this https://doc.pfsense.org/index.php/Nut_package but I get a message the command cannot be found or similar. I've tried to fix this under 2.2.6 (amd64) and 2.3.1-RELEASE-p1 (amd64).

    UPDATE -
    I decided to recklessly roll the dice since I can easily restore. After Googling deeper - I went into DIAGNOSTIC then EDIT to attempt to clean up the config.xml file. I searched for any references to packages and NUT. I found a section and attempted to delete those sections/references. I finish and save. If I reboot and/or browse back into the config.xml file the changes are gone and the references are back! WTF? lol Obviously I'm doing something wrong.

    The section looks like this (the BOLD parts are what I try to delete)

    <installedpackages><tab><name>Client Export</name>
    <tabgroup>OpenVPN</tabgroup>
    <url>/vpn_openvpn_export.php</url></tab>
    <tab><name>Shared Key Export</name>
    <tabgroup>OpenVPN</tabgroup>
    <url>/vpn_openvpn_export_shared.php</url></tab>
    **<service><service><name>nut</name>
    <rcfile>nut.sh</rcfile>
    <executable>upsmon</executable></service>

    <menu>
    <name>NUT</name>
    <tooltiptext>Set Network UPS Tools settings.</tooltiptext>
    Services
    <url>/status_nut.php</url>
    </menu></service>**

    <menu>
    <name>Cron</name>
    Services
    <configfile>cron.xml</configfile>
    <url>/packages/cron/cron.php</url>
    </menu></installedpackages>

    UPDATE #2
    I decided to attempt to manually edit a backup config file from outside of pfSense using Notepad++. I searched for and removed all sections referencing NUT. I then restored to this edited backup and…it worked. I was able to install NUT fresh and was then able to configure it from under the SERVICES->NUT menu. I configured it like I had done in the past. The UPS is recognized and seems to be fully functioning and aware of the device.