Shalla blacklist will not install/download



  • hello all 
    I cannot find an answer in forums  I just bought a netgate appliance and started to configure it for squidguard.  the shalla list will not download.  I made sure I could ping the site (per suggestion in a post here from another person with the same issue).  double checked settings and now I want to find a log file that may have a reason why it will not download.  Can anyone suggest what log file I can look at?
    or, is there a permissions issue with the folder it DL's to? if so, where does it go? /tmp?

    When I click to download the blacklist, the screen 'flashes' and 'refreshes'  but no download takes place.  I am certainly willing to reset to factory, but I'd sure like to be able to find an error message so I could resolve the issue, or find someone who has solved this problem. 
    I did install community version of pfsense 6-8 months ago to experiment and the squidguard / shalla blacklist worked fine (older version of pfsense).
    Any comments will certainly be appreciated



  • Some of the smaller appliances are limited in the way of resources and do not officially support squidguard blacklists, from what I remember.



  • Kom,
    I verified the unit was capable of squid.  After searching everywhere I could, I contacted the pfsense store in hopes they could help without burning one of my support tickets.
    The really nice guy replied, after I gave a digest of my tale of woe,,, stating mozilla firefox sometimes will prevent the shalla list from downloading/installing.
    I did a factory restore (in an effort to wipe out any mistakes I may have made, installed squid and squidguard, and did the configuration in chrome.  Success!!! the blacklist downloaded and saved, and my test of blocking gambling/dating/fortunes/porn as well as allowing a few others worked splendidly.  I did need to remember to click the green "Apply" button on the general tab of squidguard for the settings to take hold.
    What a journey for my first day with pfsense!
    I hope this will help others who have experienced my frustrations with this portion of configuration