PfSense não está autenticando no AD



  • já fiz todas as pesquisas e segui diversos tutoriais mas não estou conseguindo autenticar no AD! Seguem as confs.

    protocol version: 3
    server timeout: 25
    search scope: entire subtree
    base dn: DC=dominio,DC=intra
    authentication containers: CN=Users,DC=dominio,DC=intra
    bind credencials: dominio\administrator  senha
    User naming attribuite: samAccountName
    Group naming attribute: cn
    Group member attribute: memberOf
    Group Object Class: posixGroup

    Nas versões anteriores eu usava ok, mas na 2.3.1_1 (que estou usando agora) não está funcionando!

    No console observo os seguintes erros quando tento autenticar:
    (/var/log/system)

    
    May 27 11:29:44 pfSense php-fpm[91831]: /diag_authentication.php: ERROR! Could not bind to server Dominio.
    May 27 11:29:45 pfSense php-fpm[91831]: /diag_authentication.php: ERROR! Could not bind to server Dominio.
    May 27 11:29:53 pfSense php-fpm[91831]: /diag_authentication.php: ERROR! Could not bind to server Dominio.
    
    

    Tento o comando:

    
    ldapsearch -x -D "cn=administrator,cn=users,dc=dominio,dc=intra" -b "DC=dominio,DC=intra" -W -h "172.16.32.2" "SamAccountName=usuario"
    
    

    e recebo:

    
    ldap_bind: Strong(er) authentication required (8)
            additional info: BindSimple: Transport encryption required.
    
    

    ajuda aeee plz



  • @UnDr3aD:

    já fiz todas as pesquisas e segui diversos tutoriais mas não estou conseguindo autenticar no AD! Seguem as confs.

    protocol version: 3
    server timeout: 25
    search scope: entire subtree
    base dn: DC=dominio,DC=intra
    authentication containers: CN=Users,DC=dominio,DC=intra
    bind credencials: dominio\administrator  senha
    User naming attribuite: samAccountName
    Group naming attribute: cn
    Group member attribute: memberOf
    Group Object Class: posixGroup

    Nas versões anteriores eu usava ok, mas na 2.3.1_1 (que estou usando agora) não está funcionando!

    No console observo os seguintes erros quando tento autenticar:
    (/var/log/system)

    
    May 27 11:29:44 pfSense php-fpm[91831]: /diag_authentication.php: ERROR! Could not bind to server Dominio.
    May 27 11:29:45 pfSense php-fpm[91831]: /diag_authentication.php: ERROR! Could not bind to server Dominio.
    May 27 11:29:53 pfSense php-fpm[91831]: /diag_authentication.php: ERROR! Could not bind to server Dominio.
    
    

    Tento o comando:

    
    ldapsearch -x -D "cn=administrator,cn=users,dc=dominio,dc=intra" -b "DC=dominio,DC=intra" -W -h "172.16.32.2" "SamAccountName=usuario"
    
    

    e recebo:

    
    ldap_bind: Strong(er) authentication required (8)
            additional info: BindSimple: Transport encryption required.
    
    

    ajuda aeee plz

    Tenta fazer dessa forma e veja se funciona

    authentication containers: DC=dominio,DC=intra
    bind credencials: cn=administrador,cn=users,dc=dominio,dc=infra

    abraços

    diego



  • @didonsom:

    Tenta fazer dessa forma e veja se funciona

    authentication containers: DC=dominio,DC=intra
    bind credencials: cn=administrador,cn=users,dc=dominio,dc=infra

    abraços

    diego

    Diego, obrigado pela resposta. Desculpa a demora a responder tbm!!!

    Mas não deu, cara!!! continua sem funfar!!!! Desde o 2.3 estou nessa!  :-[



  • O usuário que você ta querendo autenticar ta dentro de CN=Users,DC=dominio,DC=intra?
    Qual porta vc ta usando?
    Consegue pingar, a partir do pfsense, o dominio dominio.infra?