Midnight commander on pfSense



  • When I ssh into pfSense I can't run mc…

    I get this error

    [2.2.6-RELEASE][root@pfSense.localdomain]/etc: mc
    common.c: unimplemented subshell type 1
    read (subshell_pty…): No error: 0 (0)

    I'm sure I was able to do so at one point, but I may have had to re-install pfSense since then.

    Is there any reason why it shouldn't work?



  • I can confirm that installing and running mc on pfsense-2.4.1 works.

    
    pkg add http://pkg.freebsd.org/freebsd:11:x86:64/latest/All/libslang2-2.3.1_1.txz
    pkg add http://pkg.freebsd.org/freebsd:11:x86:64/latest/All/mc-4.8.19_3.txz
    
    


  • Never before thought about installing MC on the pfsense box. So wanted to try it :)
    After installing the mc package (and all dependencies) same error here:

    [2.4.1-RELEASE][root@pfSense.xxx.lan]/usr/local/bin: ./mc
    common.c: unimplemented subshell type 1
    read (subshell_pty…): No error: 0 (0)



  • ok, got it figured out how to prevent the error:

    you must use the –nosubshell parameter when starting mc

    /usr/local/bin: ./mc --nosubshell
    

    to get a clear view on my screen I also changed the configuration of the putty session to use characterset CP437 to show nice linedrawing instead of characters (Window - Translation - Remote character set)


Log in to reply