/tmp/bridge_config_ath0 sets MTU 0



  • This is probably nothing, but thought it's worth mentioning. In the debug log /tmp/bridge_config_ath0, pfSense appears to be trying to set the MTU for both interfaces to 0. From what I can gather, pfSense is suppose to be setting the MTU on both interfaces to the same value.

    /sbin/ifconfig ath0 mtu 0
    
    /sbin/ifconfig re0 mtu 0
    
    /sbin/ifconfig bridge0 create
    /sbin/ifconfig bridge0 addm ath0 addm re0 up
    
    


  • Thats very strange.  I've commited code to detect an MTU of 0 and simply use 1500.



  • I've updated to the latest snapshot, and it's still happening. As well, I checked the logs, and didn't see any error.



  • You must have caught a snapshot before it was included then?



  • I last updated to pfSense-Full-Update-1.2.1-RC1-20080730-2326.tgz. And, checking in /etc/inc/interfaces.inc, I can see the check you added.



  • Try changing that blob of code to:

    		/* force all bridged interfaces to use same mtu */
    		$mtu = get_interface_mtu($config['interfaces'][$lancfg['bridge']]['if']);
    		if(intval($mtu) == 0) {
    			log_error("An error occurred while trying to obtain the MTU setting.  Using 1500.");
    			$mtu = "1500";
    		}
    
    


  • Also found the problem in pfsense_utils.inc.  Try the next snap.



  • I checked my /tmp/bridge_config_ath0

    /sbin/ifconfig ath0 down
    /sbin/ifconfig ath0 mediaopt hostap
    /sbin/ifconfig ath0 mode '11g'
    /sbin/ifconfig ath0 channel '1'
    /sbin/ifconfig ath0 -mediaopt turbo
    /sbin/ifconfig ath0 ssid 'TAMU'
    /sbin/ifconfig ath0 -hidessid
    /sbin/ifconfig ath0 -mediaopt adhoc
    /sbin/ifconfig ath0 protmode 'rtscts'
    /sbin/ifconfig ath0 mode 11g pureg
    /sbin/ifconfig ath0 -apbridge
    /sbin/ifconfig ath0 wme
    /sbin/ifconfig ath0 authmode open wepmode off
    /sbin/ifconfig ath0 txpower '99'
    /sbin/ifconfig ath0 mtu 1500
    /sbin/ifconfig ath0 up
    /usr/sbin/hostapd -B /var/etc/hostapd_ath0.conf

    ifconfig ath0 shows mtu as 2290

    I am not in bridge mode at all.

    Edit:  When I first checked the logs apbridge was enabled.  I don't know what that does but I disabled it and still get mtu of 2290.

    Edit:Edit:  apbridge is Allow intra-BSS communication when operating as an access point


Log in to reply