2.3.1_1 and just got another 502 error



  • All

    I've already posted about the 64bit going backward to 32bit (see other thread here https://forum.pfsense.org/index.php?topic=112514.0) but I've just upgraded to 2.3.1_1 from 2.3.1 hoping the 502 error would be fixed however my PRTG HTTP checker just flagged up that I was getting 502 NGINX errors again. checked the console and it is indeed so :( Any idea why it might still be doing it?

    for a little more info, everything has been stable on the previous versions and never had an issue. I'm using Intel pro cards in an Dell PC. Upgrades have never been an issue and it's always been a 64bit version as far as I know. I can temporarily fix the issue by restarting PHP-FPM but it happens again a random amount of time later.

    Swampy


  • Rebel Alliance

    If you are using it try without the ipsec widget. There seems to be some problems with that (widget only).



  • Thanks. Will try. Especially as it just failed again  although this time no 502… just completely unresponsive Web interface...i'll see how I get on with the ipsec widget disabled. Thanks again :)



  • Hi,

    same here get the error 502 bad gateway nginx and web interface has became unresponsive. A restart of PHP-FPM solve the problem. Have the last update 2.3.1_1.

    Sample of logs during unresponsive:

    01-06-2001 22:21 kernel sonewconn: pcb 0xfffff80006aeb690: Listen queue overflow: 193 already in queue awaiting acceptance (80 occurrences)
    01-06-2001 22:21 check_reload_status Could not connect to /var/run/php-fpm.socket

    Thanks



  • After removing the ipsec widget from the dashboard page I haven't had an issue….

    Is there a fix due for this sometime?



  • Today I got the same problem, WebGUI stucked forever, PHP-FPM restart helped and yes I was using IPSEC widget.
    https://redmine.pfsense.org/issues/6318



  • Same here, using the IPSec widget on the dashboard causes PHP-FPM to die after a random amount of time.
    Removing it from the dashboard for now…


Log in to reply