PfSense-CE-memstick-serial-2.3.1-RELEASE-amd64.img problem on APU1D4 with SSL



  • Hello,

    i have tried several times with 2.3.1 or 2.3, the result is the same. Here the output of "pkg update" for example.

    Updating pfSense-core repository catalogue…
    Certificate verification failed for /OU=Domain Control Validated/OU=PositiveSSL Wildcard/CN=.pfsense.org
    34401131016:error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed:/builder/pfsense-231/tmp/FreeBSD-src/secure/lib/libssl/../../../crypto/openssl/ssl/s3_clnt.c:1185:
    Certificate verification failed for /OU=Domain Control Validated/OU=PositiveSSL Wildcard/CN=
    .pfsense.org
    34401131016:error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed:/builder/pfsense-231/tmp/FreeBSD-src/secure/lib/libssl/../../../crypto/openssl/ssl/s3_clnt.c:1185:
    Certificate verification failed for /OU=Domain Control Validated/OU=PositiveSSL Wildcard/CN=.pfsense.org
    34401131016:error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed:/builder/pfsense-231/tmp/FreeBSD-src/secure/lib/libssl/../../../crypto/openssl/ssl/s3_clnt.c:1185:
    pkg: https://pkg.pfsense.org/pfSense_v2_3_1_amd64-core/meta.txz: Authentication error
    repository pfSense-core has no meta file, using default settings
    Certificate verification failed for /OU=Domain Control Validated/OU=PositiveSSL Wildcard/CN=
    .pfsense.org
    34401131016:error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed:/builder/pfsense-231/tmp/FreeBSD-src/secure/lib/libssl/../../../crypto/openssl/ssl/s3_clnt.c:1185:
    Certificate verification failed for /OU=Domain Control Validated/OU=PositiveSSL Wildcard/CN=.pfsense.org
    34401131016:error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed:/builder/pfsense-231/tmp/FreeBSD-src/secure/lib/libssl/../../../crypto/openssl/ssl/s3_clnt.c:1185:
    Certificate verification failed for /OU=Domain Control Validated/OU=PositiveSSL Wildcard/CN=
    .pfsense.org
    34401131016:error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed:/builder/pfsense-231/tmp/FreeBSD-src/secure/lib/libssl/../../../crypto/openssl/ssl/s3_clnt.c:1185:
    pkg: https://pkg.pfsense.org/pfSense_v2_3_1_amd64-core/packagesite.txz: Authentication error
    Unable to update repository pfSense-core
    Updating pfSense repository catalogue...
    Certificate verification failed for /OU=Domain Control Validated/OU=PositiveSSL Wildcard/CN=.pfsense.org
    34401131016:error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed:/builder/pfsense-231/tmp/FreeBSD-src/secure/lib/libssl/../../../crypto/openssl/ssl/s3_clnt.c:1185:
    Certificate verification failed for /OU=Domain Control Validated/OU=PositiveSSL Wildcard/CN=
    .pfsense.org
    34401131016:error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed:/builder/pfsense-231/tmp/FreeBSD-src/secure/lib/libssl/../../../crypto/openssl/ssl/s3_clnt.c:1185:
    Certificate verification failed for /OU=Domain Control Validated/OU=PositiveSSL Wildcard/CN=.pfsense.org
    34401131016:error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed:/builder/pfsense-231/tmp/FreeBSD-src/secure/lib/libssl/../../../crypto/openssl/ssl/s3_clnt.c:1185:
    pkg: https://pkg.pfsense.org/pfSense_v2_3_1_amd64-pfSense_v2_3_1/meta.txz: Authentication error
    repository pfSense has no meta file, using default settings
    Certificate verification failed for /OU=Domain Control Validated/OU=PositiveSSL Wildcard/CN=
    .pfsense.org
    34401131016:error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed:/builder/pfsense-231/tmp/FreeBSD-src/secure/lib/libssl/../../../crypto/openssl/ssl/s3_clnt.c:1185:
    Certificate verification failed for /OU=Domain Control Validated/OU=PositiveSSL Wildcard/CN=.pfsense.org
    34401131016:error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed:/builder/pfsense-231/tmp/FreeBSD-src/secure/lib/libssl/../../../crypto/openssl/ssl/s3_clnt.c:1185:
    Certificate verification failed for /OU=Domain Control Validated/OU=PositiveSSL Wildcard/CN=
    .pfsense.org
    34401131016:error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed:/builder/pfsense-231/tmp/FreeBSD-src/secure/lib/libssl/../../../crypto/openssl/ssl/s3_clnt.c:1185:
    pkg: https://pkg.pfsense.org/pfSense_v2_3_1_amd64-pfSense_v2_3_1/packagesite.txz: Authentication error
    Unable to update repository pfSense

    If you like to install an package, the SSL verification failed, if you like to do an upgrade from 2.3 to 2.3.1 the same. I have check the SHA256 Checksum, i have downloaded other IMG files, but all went into the same problem after i setup the box. The IMG file doing well in a VM Box or on other systems, so i think it is a problem with the APU1D4 System. The Install has no errors and i try a secound usb stick for the install. I don´t know what to do, cloud someone help?

    Regards
    Markus



  • After many hours and a sleepless night, here the result! It works. After i flash the APU1D4 with the latest firmware, i was able to install and configure the pfSense in Version 2.3.

    Here my result after the upgreade to 2.3.1

    Updating pfSense-core repository catalogue…
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.

    It works!

    You have to check the latest firmware and use the 2.3 IMG file for the initial installation. Howether why?! Dont know why the 2.3.1 installation file doesn´t work.

    Regards
    Markus