DNS Forwarder, additional names are not saved



  • Hello,

    Recently updated to 2.3 and everything still worked.

    Today, I tried to add a new additional name to my DNS Forwarder entry (which already contained some entries).

    Upon saving, all additional names were lost.

    Upgrading to 2.3.1 did not resolve the issue.

    Image #1 - Before saving.
    Image #2 - After saving and applying.
    Image #3 - Editing the newly created entry.

    What could be the issue? Corrupt config from before 2.3? If so, how can it be fixed?







  • I did some testing and I got it working.

    Before 2.3 I would add a new additional name like this:

    
    Host: 
    Domain: sub1.test-my-domain.se
    Description: 
    
    

    And that worked before. Now I tried with

    
    Host: sub1
    Domain: test-my-domain.se
    Description: 
    
    

    And it works again (see Image). But my old values worked, before I tried to add a new one resulting in losing all additional names.




  • I've got a similar issue, all my old aliases are working, but adding av new one on 2.3.1 makes all of them disappear.
    Did you figure this one out, or did you end up reconstructing everything on 2.3.1?
    I havent got any sub.domains like you have.

    My thread: https://forum.pfsense.org/index.php?topic=112448.0


  • Rebel Alliance Global Moderator

    Not sure what your wanting to do here, but how is leaving black a valid configuration?



  • @johnpoz:

    Not sure what your wanting to do here, but how is leaving black a valid configuration?

    I just assumed everything was correct from the beginning.
    What you see in Image #1 worked perfectly fine before 2.3 and it still did after 2.3.
    Until I wanted to add a new new host name under "Additional names".
    Which upon saving resulted in loosing all hosts under "Additional names" instead, with not message telling me why.

    Until I tried the changes in my second post, image #4.
    And It all works again.

    So I must have used it wrong from the beginning, but it still somehow worked.