DHCP server backup/restore not working?



  • Hi,

    I'm trying to backup the dhcp server configuration of my old pfsense fw to a new one; apparently this is not working.

    I get no error, both during the backup and the restore, but the new firewall never gets the configuration. I'm quite sure I did the same some time ago, so it could be a new bug.

    I tried both with the full backup and with s simplified copy (a single interface); you can find attached this last one.

    Thanks,
    Alberto

    dhcpd-config-fw02.consulthink.it-20160530110447.txt


  • Rebel Alliance Global Moderator

    what is the error you get in backup?

    And are you trying to move these configs from same version of pfsense, are the dhcp scopes the same, etc..



  • Hi John, thanks for your reply.

    I get no error in backup, and no error in restore. Pfsense version is the same (2.3.1_1), both firewalls are virtual machines.

    DHCP scope is the same, and I've on purpose limited my tests (well, the last ones) to the single interface you can find in the xml file.

    I've visually inspected the file and I haven't found anything obviously wrong, that's why I'm perplexed.

    Best regards,
    Alberto


  • Rebel Alliance Global Moderator

    My bad I missed the "no" in your post…

    Well that makes more sense... I will try and duplicate what your doing.



  • Still trying, and I could have a hint.

    I was trying to restore dhcp server settings having logged in with my Active Directory user; now I've tried again using the local admin account, and it's working.

    I'm quite sure the AD user has full privileges (when I configured it I assigned it all the available privileges), but who konws? Could this be the problem?

    I'll keep testing and keep you updated.

    Regards,
    Alberto



  • Check that the user you were logged on with didn't have the "User - Config: Deny Config Writes" privilege turned on. There was a bug in 2.2.* that made the privilege inoperable but was fixed in 2.3.


  • Rebel Alliance Global Moderator

    There was a thread somewhere about write to config permissions.  I recall seeing a thread about it a few days ago or so.