Update to 2.3.1 unbound problem



  • Hello everyone,

    I successfully upgraded to 2.3.1 and the GUI just looks awesome, kudos to the devs!
    Before I upgraded from 2.2.6 my static dhcp mappings were normally resolved from unbound, but since the upgrade to 2.3.1 unbound won't resolve any of my static mappings anymore. It worked fine in 2.2.6.
    After further investigation I found the file /var/unbound/host_entries.conf and it contains the host overrides from the dns-forwarder. I entered my static mappings by hand in the forwarder and now I can resolve them with unbound.
    Also the normal DHCP leases work fine and are written in /var/unbound/dhcpleases_entries.conf, but the static mappings are missing completely.

    Can someone confirm this problem/behaviour?

    Thanks and Greetz


  • Rebel Alliance Global Moderator

    "I entered my static mappings by hand in the forwarder "

    I am confused are you using the forwarder or the resolver (unbound).. What would putting stuff in the forwarder have to do with unbound?

    Do you have checked

    Register DHCP static mappings in the DNS Resolver If this option is set, then DHCP static mappings will be registered in the DNS Resolver, so that their name can be resolved. The domain in System: General Setup should also be set to the proper value.

    In the resolver(unbound) section?



  • Thank you for your quick response!

    I am confused are you using the forwarder or the resolver (unbound).. What would putting stuff in the forwarder have to do with unbound?

    I'm using the resolver for my clients (unbound), but the mappings from the forwarder (which works local because I use unbound via OVPN) are written in the file for unbound, which confused me too (file /var/unbound/host_entries.conf).

    Do you have checked

    Register DHCP static mappings in the DNS Resolver If this option is set, then DHCP static mappings will be registered in the DNS Resolver, so that their name can be resolved. The domain in System: General Setup should also be set to the proper value.

    Yes.
    As i mentioned the normal DHCP releases (the option above that) works fine, but not the DHCP static ones.


  • Rebel Alliance Global Moderator

    Dude your using both the forwarder and resolver?

    "but the mappings from the forwarder (which works local because I use unbound via OVPN) are written in the file for unbound"

    All I can tell you is I have it checked to create static entries.  When I create a static entry it resolves..  All I am using is the resolver.  Doesn't even have to be a valid static entry.. I can then cat /etc/hosts file and there it it my entry

    So your going to have to be a little more clear on what your doing exactly and what you think is not working.  Because I am on 2.3.1 and not having any issues with static dhcp settings being resolved by unbound..






  • Alright here is my setup:

    dns-forwarder works local to resolve the hostname for my OVPN Connection. Then I'm using unbound with the OVPN connection to serve my clients with DNS requests. I do this to prevent DNS-leaks, so far so good. It worked fine in 2.2.6 so I did not thought that this kind of setup would be a problem in 2.3.1. What file in /var/unbound/ is filled with the static mappings?

    If I go to Services -> DNS-Forwarder -> "Host overrides" These hosts are written in the file located at /var/unbound/host_entries.conf which seems odd to me because its the forwarder and not unbound.

    When I tick the

    Static DHCP
    Register DHCP static mappings in DNS forwarder If this option is set, then DHCP static mappings will be registered in the DNS forwarder, so that their name can be resolved. The domain in System: General Setup should also be set to the proper value.

    at the dns-forwarder, it fills all static entries again in  /var/unbound/host_entries.conf but it just won't work when I do the same in the unbound section.

    If you need any further information just tell me please!

    //edit: I think I found the problem. Using both, dns-forwarder and unbound is a conflict. If I use unbound only, it works like you showed in your screenshots.
    Still it's pretty odd that it worked fine in 2.2.6 but not in 2.3.1. The dns-forwarder seems to have more control over that file than unbound.


  • Rebel Alliance Global Moderator

    So your not understanding the difference between a host override and a register dhcp static it seems.

    No shit the forwarder and resolver configurations are different.  If you put in a host override in the forwarder, no its not going to be seen by the resolver.

    If you actually created dhcp static (reservations) then it would be seen by both forwarder and resolver.

    If you want to use host overrides then yes if using forwarder you put them in forwarder section, if using resolver then resolver section.  If you want to use both then have to put them in both.  Only the dhcp static reservations would be shared.  depending if you told both the resolver and forwarder to use them.



  • So your not understanding the difference between a host override and a register dhcp static it seems.

    I do but i wrote it in a bad way, my bad. Let me try to explain it better:

    DNS-Forwarder -> Enabled

    nothing more, no DHCP mapping, no host overrides nothing.

    Now -> DNS-Resolver -> Enabled + -> Static DHCP Register enabled

    All static mappings won't get resolved now because there is only this in the /var/unbound/host_entries.conf file

    local-zone: "localdomain" transparent
    local-data-ptr: "127.0.0.1 localhost"
    local-data: "localhost A 127.0.0.1"
    local-data: "localhost.localdomain A 127.0.0.1"
    local-data-ptr: "::1 localhost"
    local-data: "localhost AAAA ::1"
    local-data: "localhost.localdomain AAAA ::1"
    local-data-ptr: "... FW.localdomain"
    local-data: "FW.localdomain A ..."
    local-data: "FW A ..."

    Which reprents the settings in the DNS-Forwader.

    It does not matter if I enable the DHCP static mapping at unbound or not, because it won't put it in this file.

    But when I enable the DHCP static mapping at the !DNS-forwarder! every static mapping is showing in /var/unbound/host_entries.conf

    Hope I could explain it in a better way, maybe you can reproduce this issue with a testmachine.