USB 3.0 3g Modem



  • Hi all
    I recently bought an apu 2c2 board for use with pfsense. This board have two USB 3.0 ports in rear panel and USB 2.0 internal connector.
    When I plug mi usb modem (Huawei E-1752 or Huawei E122) in USB 3.0 port it's detected but not like a 3g modem, in dmesg I only see that:

    ugen0.3: <vendor 0x12d1="">at usbus0

    But when I plug the 3G modem in USB 2.0 all necesary devices are created:

    ugen1.3: <huawei technology="">at usbus1
    ugen1.3: <huawei technology="">at usbus1 (disconnected)
    ugen1.3: <huawei technology="">at usbus1
    u3g0: <huawei 0="" 3="" technology="" huawei="" mobile,="" class="" 0,="" rev="" 2.00="" 0.00,="" addr="">on usbus1
    u3g0: Found 5 ports.
    umass0: <huawei 0="" 3="" technology="" huawei="" mobile,="" class="" 0,="" rev="" 2.00="" 0.00,="" addr="">on usbus1
    da0 at umass-sim0 bus 0 scbus2 target 0 lun 0
    da0: <huawei sd="" storage="" 2.31="">Removable Direct Access SCSI-2 device
    da0: 40.000MB/s transfers
    da0: Attempt to query device size failed: NOT READY, Medium not present
    da0: quirks=0x2 <no_6_byte>In Debian I had a similar problem but it's clear modifying /etc/usb_modeswitch.conf adding this parameter: SetStorageDelay=4.

    Many thanks.</no_6_byte></huawei></huawei></huawei></huawei></huawei></huawei></vendor>



  • Is the latest BIOS installed? In some rarely cases some USB 2.0 devices will not really fine running in the
    USB 3.0 ports, perhaps this is one of this case. I would suggest to use the USB 2.0 Port instead of the
    USB 3.0 ports.



  • Thank you for your answer.
    The USB port run fine with pendrives 2.0. I have installed pfsense from usb 2.0 memory stick plugged in USB 3.0 port. without problems.
    I can't use USB 2.0 ports because I must to keep open the case to use it.