Upgrade to 2.3.1_1 : serial terminal disabled



  • Hi,

    I use an allix APU with pfSense 2.3. I upgraded to 2.3_1 but after successful upgrade the option "Enables the first serial port with 115200/8/N/1 by default, or another speed selectable below." (in Advanced Menu) is unchecked.

    After "boot complete" I can't see anything. And I only have a serial and no VGA output on this equipment.

    Why is the serial port disabled after the upgrade?

    thank you



  • Have you tried different baud rates just in case it's getting set to something you don't expect?

    I remember reading back a while that a few people had issues with serial terminals where they couldn't get any output if they connected before the box had fully (or partly) booted.
    Seemed a little odd to me, but more than one person reported having the same issue.

    Might be worth a hunt through the forums on previous serial port issues.



  • Yes I try with two speed 9600 and 115200.

    If I check the checkbox the serial terminal works. The question is : why the checkbox is unchecked after upgrade ?  :-\

    thank you



  • It would only be unchecked where it was unchecked before the upgrade. The nanobsd serial versions don't even give you an option to enable the serial console, it's always on. Is that a full install?



  • Yes a full install because I use a SSD, not a flash card.

    When I try to reset default configuration the serial is disabled too (it was not the case with 2.2.x)



  • The behavior there is the same as it's always been. The serial console option in the config doesn't get set during install. You need to set it if you want to ensure the serial console's retained.

    If there is any difference between versions there, it's attributable to a bug we fixed where the configured console settings (in your case, no serial console) weren't being applied correctly post-upgrade nor post-factory defaults.



  • OK, so I understand it was a bug and now a normal operation ?

    Could you please precise the id of the bug that you fixed ?



  • @xhark:

    OK, so I understand it was a bug and now a normal operation ?

    Could you please precise the id of the bug that you fixed ?

    https://redmine.pfsense.org/issues/6120

    the scope is potentially wider than just what's described there, but the root of it is your configured console settings weren't always applied. You're not configured for a serial console. So now it is applied correctly. Enable the serial console, and it'll be applied correctly as such.