Install to Harddrive/flash issues.



  • Hey all,

    Using the latest snapshot ISO (20080730-0226), I tried a standard boot and install onto a platform that hadn't worked with 1.2 (NICs weren't supported in FreeBSD < 7.0).  Everything goes well, until the system reboots and tries to load the OS.  It just halts after reading the kernel image:

    <manual screen="" shot="">F1    FreeBSD

    Default: F1

    BTX loader 1.00  BTX version is 1.02
    Consoles: internal video/keyboard
    BIOS drive C: is disk0
    BIOS 639kB/2087552kB available memory

    FreeBSD/i386 bootstrap loader, Revision 1.1
    (sullrich@freebsd7-releng_1_2.geekgod.com, Wed Jul 30 01:41:57 EDT 2008)
    Loading /boot/defaults/loader.conf
    /boot/kernel/kernel text-0x80bd53 data=0xb5524+0x6b0dc /
    /
    Hit [Enter] to boot immediately, or any other key for command prompt.
    Booting [/boot/kernel/kernel]…
    /boot/kernel/acpi.ko text=0x520e8 data=0x23a0+0x186c syms=[0x4+0x85x0+0x4+0xb056]
    /</manual>

    I've tried messing around with the IDE controller in the BIOS (SATA/PATA enabled/disabled), installing the bootblocks in both modes, and with/without grub, to no avail.  Also, with the default BIOS settings, I've installed FreeBSD 7 with no problems on the internal SATA drive.

    The system is an Asus barebone, intel ICH7 based:
    http://www.asus.com/products.aspx?l1=9&l2=40&l3=116&l4=0&model=1969&modelmenu=2

    Let me know if anyone has any ideas, or needs more info, or wants one to play with.  I haven't given back to pfSense yet, I figure I'm coming due ;)

    Thanks!


Log in to reply