SG-4860 port enumeration


  • Galactic Empire

    Just taken delivery of a nice shiny new SG-4860

    My WAN & LAN ports aren't correct out out the box, when I connected the WAN port to my local LAN it didn't pick up an address via DHCP.

    When I take the rj45 out of the WAN interface and connect it into the LAN port the WAN interface in the console comes up with a DHCP address.

    I'd like the ports in future to enumerate correctly if I do a factory default, rather than having to faff about  with the interfaces.

    As of now :-

    WAN (wan)      -> igb1
    LAN (lan)        -> igb0
    OPT1 (opt1)    -> igb2
    OPT2 (opt2)    -> igb3
    OPT3 (opt3)    -> igb4
    OPT4 (opt4)    -> igb5

    What I'd like it to be to match the front :-

    WAN (wan)      -> igb0
    LAN (lan)        -> igb1
    OPT1 (opt1)    -> igb2
    OPT2 (opt2)    -> igb3
    OPT3 (opt3)    -> igb4
    OPT4 (opt4)    -> igb5

    The output from ifconfig :-

    [2.3.1-RELEASE][admin@pfSense.localdomain]/root: ifconfig -a
    igb0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:08:a2:0a:9d:cb
    inet6 fe80::208:a2ff:fe0a:9dcb%igb0 prefixlen 64 scopeid 0x1
    nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect
    status: no carrier
    igb1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:08:a2:0a:9d:cc
    inet6 fe80::1:1%igb1 prefixlen 64 scopeid 0x2
    inet 0.0.0.0 netmask 0xff000000 broadcast 255.255.255.255
    nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    igb2: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:08:a2:0a:9d:c7
    inet6 fe80::208:a2ff:fe0a:9dc7%igb2 prefixlen 64 scopeid 0x3
    nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect
    status: no carrier
    igb3: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:08:a2:0a:9d:c8
    inet6 fe80::208:a2ff:fe0a:9dc8%igb3 prefixlen 64 scopeid 0x4
    nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect
    status: no carrier
    igb4: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:08:a2:0a:9d:c9
    inet6 fe80::208:a2ff:fe0a:9dc9%igb4 prefixlen 64 scopeid 0x5
    nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect
    status: no carrier
    igb5: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:08:a2:0a:9d:ca
    inet6 fe80::208:a2ff:fe0a:9dca%igb5 prefixlen 64 scopeid 0x6
    inet 172.16.1.25 netmask 0xffffff00 broadcast 172.16.1.255
    inet6 fdee:87cd:d40:1:208:a2ff:fe0a:9dca prefixlen 64 autoconf
    nd6 options=23 <performnud,accept_rtadv,auto_linklocal>media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active</full-duplex></performnud,accept_rtadv,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></up,broadcast,running,simplex,multicast></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></up,broadcast,running,simplex,multicast></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></up,broadcast,running,simplex,multicast></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></up,broadcast,running,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></up,broadcast,running,simplex,multicast></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></up,broadcast,running,simplex,multicast>



  • The auto-assigned order is correct, that's how the ports are on the system from left to right. Left-most is igb1, next to that is igb0, then igb2, 3, etc. Check the quick start guide.


  • Galactic Empire

    So shouldn't the case of the SG-4860 have the left most port marked as LAN not WAN.

    https://portal.pfsense.org/docs/manuals/sg-4860/io-ports.html

    As I said in my port I had to move the interfaces over in the GUI so they matched the front of the SG-4860.

    All up now and working, apart from a few minor niggles I have to say I'm very impressed.


  • Netgate

    When you are looking at the ports left to right: igb1, igb0, igb2, igb3, igb4, igb5.


  • Galactic Empire

    You're not getting what I'm saying.

    Out of the box my SG-4860 had the WAN and LAN ports reversed so the port marked WAN on the front of the router was actually the LAN port on the web GUI.

    I had to swap in the GUI in the Interfaces -> Assign section ibg0 & ibg1.

    The ports marked on the outside of the box read WAN, LAN, OPT1 - 4.

    Anyhow everything is working a treat, I'm well chuffed.