VLAN Weirdness



  • Hi

    My Qnap NAS has 2 gigabit Ethernet ports and I run a PFsense on a virtual machine on the NAS, it works great auto loads if the NAS is ever powered off and back on and all is well, I connected one interface to a DLink semi managed switch and I run 2 Vlans on one of the physical interface. which effectively gives me 3 interfaces on the pfsense router, I use it to have 2 WAN (two separate providers) and one LAN in a load balance / failover arrangement. my problem is each time I reboot PFsense it "Forgets" how to connect to one of the Vlans, to fix it I have to change the VLAN to a different number and change it back again to make it work does any one know why?

    My Set up
    Eth1 - VLAN1 and VLAN20
    Eth0 - WAN1

    VLAN 1 is the LAN
    VLAN 20 is WAN2

    on reboot VLAN 20 is unreachable and this message appears during boot up of the PFsense on the console

    Arpresolve: Can't Allocate IIinfo for 192.168.20.254 on EM1_VLAN20

    its not a major issue just a bit annoying having to adjust the VLAN settings each time it restarts (although this isn't often as its very reliable!)