NAT on WAN2 failed if WAN1 down



  • Hello,

    I have setup a pfSense (2.3.1-RELEASE-p1) with 1 LAN and 2 WAN. Both 2 WAN are PPPoE connections to 2 ISP. For internet access, I've configured 3 gateway groups: 1 for load balancing and 2 for failover, also set the rules for LAN to access internet via those groups.

    I've add 2 rules for port forwarding TCP/80 from 2 WAN to an internal ip address:

    | Interface | Protocol | Source Address | Source Port | Destination Address | Destination Port | NAT IP | NAT Port |
    | WAN1 | TCP | * | * | WAN1 Address | 80 (HTTP) | 192.168.1.100 | 80 (HTTP) |
    | WAN2 | TCP | * | * | WAN2 Address | 80 (HTTP) | 192.168.1.100 | 80 (HTTP) |

    Both 2 above rules is set NAT Reflection: Enable (NAT + Proxy). Other settings are left default.

    When both 2 WAN online, from the internet, I can telnet port 80 on each WAN's public IP address, means above rules work. But if the WAN1 down, I cannot telnet port 80 on WAN2. From the internal host 192.168.1.100, it can ping to the internet.

    There is another problem, if WAN1 down, squid proxy cannot access internet, every clients in LAN cannot access web, so I have to disable squid to allow web access.

    Can anyone help me why, and how to fix this?

    Regards,

    Anh


  • Rebel Alliance Developer Netgate

    Your telnet to port 80 is likely going to squid, and then failing because squid can't get out (no default gateway).

    Activate Default Gateway Switching under System > Advanced, Miscellaneous.


Log in to reply