2.3.1 Serial Console Install Images Broken?



  • Hey all,

    I tried doing an install on a PC Engines APU2C4 board last night.  First I tried the Serial Console memstick installer.  This failed to boot up from the USB stick.  It got through loading the kernel and starting the boot process, but then never got tot he point of presenting me with the option to start an install, and instead failed with a bunch of write errors displayed in the console.

    Next I tries the 2.3.1 Serial console CD ISO, burned it, and tried to install from it, and had a similar problem.  Kernel loaded during boot, but never got to the point of being presented with a install option as the root file system on the CD ISO failed to mount.

    I was - however - able to install by grabbing the 2.3 Serial Console Memstick image, dd:ing it to my USB stick.  The install went smoothly with the 2.3 image (except for a weird echo where each character was repeated twice in the boot menu (grub?))  Once 2.3 was installed, using the web interface to upgrade to 2.3.1_1 went without a hitch, and it appears to be working perfectly.

    I suspect the serial console images for 2.3.1 are borked.  Either that, or there is some sort of compatibility issue with the APU2C4 with them, that didn't exist in 2.3.

    Just figured I'd mention it here, if anyone else has had similar issues!

    –Matt



  • Nothing wrong with the serial memstick. There is no serial ISO so no idea what you were doing there. Any read errors would be something at the OS level if it's software at all, and the OS changes between 2.3 and 2.3.1 are very minimal. My best guess is the memstick didn't write out successfully the first time around.



  • I've just recently got an apu2c4 and i haven't had any trouble installing from pfSense-CE-memstick-serial-2.3.1-RELEASE-amd64.img file.

    What usb stick are you using? i'm using a sandisk usb 3.0 in the front usb 3.0 ports, have also tried a corsair flash voyager usb 2.0 stick.

    I've read elsewhere (don't remember where) that people have got around the problems by using the internal usb 2.0 header instead of the front usb 3.0 ports.