Unable to make a "pipe" (|) symbol, how to change keyboard layout?



  • Hi!

    I am running Pfsense on ESXI and when I enter the pfSense shell (i.e. the option "8", not the webgui) I must have chosen the wrong keyboard layout at configuration since I am unable to make a pipe sign "|".
    I have a swedish keyboard layout and all other characters and special characters work, thats the weird part. Even tried the "alt-code" for pipe which should be alt+124 but that does not make the pipe symbol.

    I am wondering if I should enable and use SSH instead?
    I am trying to install this script, see "Installation":
    https://github.com/gozoinks/unifi-pfsense

    The shell should work too, right?
    Would be grateful on how to change the keyboard layout or info on how to make a pipe symbol.

    Best Regards - TheSwede86



  • You have to type 124 on the keypad, believe it or not, instead of using the numbers above your letters.



  • @KOM:

    You have to type 124 on the keypad, believe it or not, instead of using the numbers above your letters.

    Thanks but I know that and that does not work either.
    There seems to be a problem with ESXI since I am using the webinterface for ESXI and when trying to make a pipe on the computer I am using to connect to the webinterface it works, both the symbol (in my case ALT GR + the key to the right of my left "Shift" button) and the alt-code ALT+124 on the numpad. :(

    Edit:
    Solved this by enabling "Secure Shell" (option 14) and then used my SSH client to run the command and then all the characters worked (or at least copy-paste).