How to set-up MultiWAN so one client traffic uses the 1 WAN?



  • Here is my situation – I have two WANs.
    It is the same ISP... but I just got another modem and it works.
    I have two modems -- one is going into WAN on the pfSense box.
    This has worked for a year.

    I asked for another 'link' with a new IP Address and they advised me what to do.
    It works.
    This other link is going into OPT1 on the pfSense box.
    I enabled the interface and it got an IP Address.
    I can ping this IP Address from a PC in Pakistan.

    NOW -- I do not want to set-up a MultiWAN for the purpose of failover.

    I want to experiment with this.

    How do I take my desktop PC and route ALL traffic through this other WAN/OPT1 link through pfSense?
    It can be done with Virtual IP's because I've done it a year ago... but I have not done it with another WAN interface.

    For instance -- if I go to IPChicken, it displays my IP Address I've always had.
    I want to enable this routing to go through WAN2(OPT1) and then it would display the other IP Address.
    I've had this working for Virtual IPs a while ago, but not a different interface.

    How would I achieve this?
    I want to take 10.0.0.2 and route ALL of that Internet traffic through WAN2 (OPT1).



  • Define your gateways (under system > routing > gateways tab), create a permit rule on your LAN interface that matches your private IP address 10.0.0.2, under this rule in the advanced option, select gateway, choose your gateway you want the rule to use.

    Make sure that this rule you created is listed ABOVE the permit any rule at the bottom of the interface rules.  (this is essentially a policy route matching 10.0.0.2 route out WAN2)

    There are other quirks you gotta watch out for as well such as making sure you have a NAT rule in place for allowing 10.0.0.2 to be natted out the 2nd internet connection.  This is really a basic configuration you're asking for, it gets complex once you start placing VPN's and DMZ interfaces in the mix, but not so bad once you start to understand WHY it is the way it is.


Log in to reply