PFSENSE 2.3.1-RELEASE-p1 - Bind package - Query Refused



  • Hello,

    I recently install a pfsense PFSENSE 2.3.1-RELEASE-p1 with the newest Bind package.

    Here is my conf :

    • Bind listen on all interface : LAN, WAN, OPENVPN
    • ACL for the entire network 192.168.10.0/24
    • Created a View and used it in dns zone

    –-> Primary Zone :

    $TTL 3h
    ;
    $ORIGIN homelab.local.
    
    ;	Database file homelab.local.DB for homelab.local zone.
    ;	Do not edit this file!!!
    ;	Zone version 2464970132
    ;
    homelab.local.	 IN  SOA pfsense.homelab.local. 	 zonemaster.homelab.local. (
    		2464970132 ; serial
    		1d ; refresh
    		2h ; retry
    		4w ; expire
    		1h ; default_ttl
    		)
    
    ;
    ; Zone Records
    ;
    @ 	 IN NS 	pfsense.homelab.local.
    @ 	 IN A 	192.168.10.254
    livebox 	 IN A  	192.168.20.1
    pfsense 	 IN A  	192.168.10.254
    

    –-> Named.conf

    #Bind pfsense configuration
    #Do not edit this file!!!
    
     key "rndc-key" {
            algorithm hmac-md5;
            secret "KtJfTQs4NZBAgEwmFuNfCA==";
     };
    
     controls {
            inet 127.0.0.1 port 953
                    allow { 127.0.0.1; } keys { "rndc-key"; };
     };
    
    options {
            directory "/etc/namedb";
            pid-file "/var/run/named/pid";
            statistics-file "/var/log/named.stats";
            max-cache-size 256M;
            listen-on-v6 { any; };
            listen-on { any; };
            forwarders { 80.10.246.2;81.253.149.9;192.168.20.1; };
            version none;
    
    };
    
    logging {
            channel custom {
                    syslog daemon;
                    print-time no;
                    print-severity yes;
                    print-category yes;
                    severity error;
                    };
            category default { custom; };
    };
    
    acl "homelab.local" {
            192.168.10.0/24;
    };
    
    view "homelab.local" {
            recursion yes;
            match-clients { none; };
            allow-recursion { homelab.local; };
    
            zone "homelab.local" {
                    type master;
                    file "/etc/namedb/master/homelab.local/homelab.local.DB";
                    allow-query { homelab.local; };
                    allow-transfer { none; };
                    allow-update { none; };
            };
    
            zone "." {
                    type hint;
                    file "/etc/namedb/named.root";
            };
    
    };
    

    when i tried to resolved I get Error : Query Refused. I don't find why, can you help ?

    thanks



  • match-clients { none; };

    fix this


Log in to reply