PfSense on KVM: cannot boot and NAT not working



  • Hi.
    I have one pfSense system running on a KVM virtual machine (running on Proxmox 3.4).
    It is configured with one virtio RAW disk and 5 virtio networking devices.
    The machine was running very well until I had to migrate it to another Proxmox server.
    After that, the machine is not booting (it was hanging as the attached screenshot) unless I disable the KVM virtualization (which was enabled before the migration).
    When I managed to make it boot I realized that the NAT features were not working on it, and I had a lot of errors about the bogus file which could not be found.

    The strange thing is that I have the same problems even if I try to restore the virtual machine from a backup file (I tried two different backups and got the same problem).

    I'm thinking about something like a corrupted image file, but it's strange as I tried the backup file as well.

    Could you help me please?

    Thank you very much!
    Bye
    ![Screen Shot 2016-06-07 at 18.44.02.png](/public/imported_attachments/1/Screen Shot 2016-06-07 at 18.44.02.png)
    ![Screen Shot 2016-06-07 at 18.44.02.png_thumb](/public/imported_attachments/1/Screen Shot 2016-06-07 at 18.44.02.png_thumb)


Log in to reply