PF sense amd64 hangs at install



  • Weird

    Pfsense was running fine for a week or two, but suddenly, DNS IP's suddenly not receivable by DHCP.
    Even using fixed IP's and DNS, no internet connection.

    So as test I hooked up a laptop directly to the modem and yes, worked without any problems.

    Next stap was chacking the harddrive well a 120GB SSD but no errors.

    So, re-install but all re-install's fails.
    The kernel loads but get's stuck at: Trying to mount root from ufs:/dev/ufs/pfSense [ro]…
    And under that, a character square block

    The router is just a small computer based on a dual core intel atom 2ghz hyper threading , 2GB ram 6 1gbps ports.

    Any ideas?



  • About the system:

    ACPI on, AHCI on, legacy boot off.

    The unit has two USB2.0 ports , both tested.

    The USB stick could install Linux mint fine on a computer so I doubt that the usb stick is the problem.
    PFsense hangs now approx 12 hours since latest attempt.

    Wait will test legacy on, hci off etc.



  • Turning on legacy mode en the setup goes one step further
    I choose single user, kernel loads

    And oh, boot is going one step further : Enter full path name of shell or RETURN for /bin/sh:
    So I press enter : system hangs.  I type /bin/sh: <enter>Then an error : init: can't exec /bin/sh: for single user : no such file or directory.

    So I rebooted for the (forgot how many times but this time I did choose Multiple users and what a surprise, setup continues to the "graphical" setup.

    So case solved. Still weird that single user setup fails.</enter>


Log in to reply