DHCP/PXE stops working



  • For some reason I can no longer get any system to perform a PXE boot. pfSense no longer offers an IP address to a PXE client. This has been working fine for ages, and it suddenly stopped yesterday. The Network Booting options under DHCP Server seem to be OK.

    I'm really stumped, and can only think that a reboot is required to sort that out - not very scientific…



  • If it's been working fine until now then something must have changed. Have there been any changes you're aware of? A version upgrade, or something new introduced into the network?

    Screenshots help a great deal if you want help. Detailed information too - just saying "It was working and now it isn't" doesn't give much of anything to go on.



  • I know I'm not giving much of a clue, but I don't know where to look. I'm not familiar enough with FreeBSD to know how to do a screenshot (shame on me…:( )

    I did upgrade to 2.3.1-RELEASE (i386) last week but everything was working normally after that.

    I tried copy & paste from the relevant DHCP server page:

    Network Booting
    Enable Enables network booting
    Next Server
    192.168.1.2
    Enter the IP address of the next server
    Default BIOS file name
    gpxelinux.0
    UEFI 32 bit file name
    UEFI 64 bit file name
    Both a filename and a boot server must be configured for this to work! All three filenames and a configured boot server are necessary for UEFI to work!
    Root path
    /mnt/nas/tftproot/pxe/
    string-format: iscsi:(servername):(protocol):(port):(LUN):targetname
    Save

    I remember doing something yesterday regarding using DNS for resolving local hostnames, but can't see how that would have caused the problem.



  • @Balanga:

    I remember doing something yesterday regarding using DNS for resolving local hostnames, but can't see how that would have caused the problem.

    You remember doing something? What exactly? If you remember what you did, have you tried un-doing it and seeing whether that resolves your PXE issue? Regardless of whether you think it has anything directly to do with your problem, if it was the only change made on the same day your net boot issues began, then it sounds like too big a co-incidence to ignore.



  • I decided to do the old Windows trick - switch it off and switch it back on (reboot actually)  and lo and behold it started working again….

    At least I'll know what to do if it happens again.


Log in to reply