Warning: preg_grep():



  • Hey Guyz

    I'm totaly new to pfSense and have got it all to run except for access to my own servers locally.
    I have alot of websites that I host, but when I try to access them I'm asked to enter credentials. Thats should not happen :-)

    When I do that I get the following error:

    Warning: preg_grep(): Compilation failed: PCRE does not support \L, \l, \N, \U, or \u at offset 11 in /etc/inc/auth.inc on line 109 Warning: array_shift(): The argument should be an array in /etc/inc/auth.inc on line 109 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/auth.inc:109) in /etc/inc/auth.inc on line 40 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/auth.inc:109) in /etc/inc/auth.inc on line 41 You must enter valid credentials to access this resource.

    I'm totaly lost in what to do here.
    Websites are all on Windows 2003 servers and it has run perfectly using a Zywall 5 with the same config as I have tried to adobt to the pfsense. Running 1.2RC4

    I really hope that you can help me out. Am I missing some simple setup ?

    Cheers



  • If you are using port forwarding and you are trying to access your servers from the inside using the external IP address, you will need to enable NAT reflection. Go to System>Advanced and clear the checkbox that says disable NAT reflection.


Log in to reply