Problemas Squid Autenticando no AD 2012 - RESOLVIDO



  • Boa tarde pessoal.

    Alguém está tendo esse erro:
    WARNING: ntlmauthenticator #Hlpr0 exited

    Cenário: PFSense 2.2.6 + Squid3 + SquidGuard-devel + Windows 2012.

    O PFSense é inserido no domínio, eu consigo ter todas as respostas ao fazer consultas com os comandos

    wbinfo -t
    wbinfo -g
    wbinfo -u
    net ads info e etc.

    Porém, ao ativar a opção em: Proxy Server: Authentication - Winbind NTLM, nos logs de cache dos Squid aparece o erro: WARNING: ntlmauthenticator #Hlpr0 exited

    Gostaria de saber se alguém já teve esse problema, se conseguiu resolver, e qual foi a solução?

    Segue o erro correto:

    2016/06/15 14:50:55 kid1| WARNING: ntlmauthenticator #Hlpr0 exited
    Shared object "libkrb5.so.3.3" not found, required by "ntlm_auth"

    Obrigado.
    Rogério



  • Pessoal.

    Resolvi meu problema dessa forma.

    ln -s /usr/local/lib/libpopt.so.0.0.0 /usr/pbi/squid-amd64/local/lib/libpopt.so.0
    ln -s /usr/local/lib/libgssapi_krb5.so.2.2 /usr/pbi/squid-amd64/local/lib/libgssapi_krb5.so.2.2
    ln -s /usr/local/lib/libkrb5.so.3.3 /usr/pbi/squid-amd64/local/lib/libkrb5.so.3.3
    ln -s /usr/local/lib/libk5crypto.so.3.1 /usr/pbi/squid-amd64/local/lib/libk5crypto.so.3.1
    ln -s /usr/local/lib/libcom_err.so.3.0 /usr/pbi/squid-amd64/local/lib/libcom_err.so.3.0
    ln -s /usr/local/lib/libtalloc.so.2 /usr/pbi/squid-amd64/local/lib/libtalloc.so.2
    ln -s /usr/local/lib/libtevent.so.0 /usr/pbi/squid-amd64/local/lib/libtevent.so.0
    ln -s /usr/local/lib/libtdb.so.1 /usr/pbi/squid-amd64/local/lib/libtdb.so.1
    ln -s /usr/local/lib/libwbclient.so.0 /usr/pbi/squid-amd64/local/lib/libwbclient.so.0
    ln -s /usr/local/lib/libkrb5support.so.0.1 /usr/pbi/squid-amd64/local/lib/libkrb5support.so.0.1
    ln -s /usr/local/lib/libintl.so.8 /usr/pbi/squid-amd64/local/lib/libintl.so.8

    Valew.



  • Amigo eu usei essa dica para o 2008 e resolveu também .