[resolvido] pf2ad não instala squidguard



  • Bom dia

    Estou tentando instalar o pf2ad no squid 2.3.1, instalacao limpa, nova.
    Rodo o script, ele instala o samba, consigo colocar no AD, esta autenticando, tudo certinho.

    mas não tem a aba do squidguard no menu.

    Tentei instalar pelo gerenciador de pacotes, instalou e apareceu normal, mas toda vida que eu tento configurar os dados de autenticacao no LDAP (primeira tela), ao aplicar ele da um refresh na tela, não salva (fica em branco o que eu digitei) e noto no canto superior da tela um alerta do pfsense dizendo que "restaurou" a configuração em XML de um backup.

    alguém pode me ajudar? porque será que não instalou o squidguard durante o script do pf2ad ?

    estou usando este video como tutorial
    Youtube Video

    também ja instalei anteriormente sem problemas nas versões antigas (2.2) mas nessa 2.3 é a primeira vez



  • Ja tentou contato com o Luiz Gustavo, desenvolvedor do pacote?

    http://pf2ad.mundounix.com.br/pt/index.html#contact



  • Bom dia !

    Estou com um problema parecido.

    Estou usando a versão 2.3.1 e utilizei o pf2ad. Em relação ao Squid tudo funciona normal, inclusive a autenticacão, porém a autenticação pelo AD no Squidguard não funciona. Já tentei várias vezes e nada.

    Alguém tem alguma dica?

    Grato a todos.

    Completando a informação: Se o DC for um Windows 2008 R2 ou Windows 2012 R2 tudo funciona ok porém se o DC for um Samba 4 somente o Squid funciona e o SquidGuard não.



  • @andrefreire:

    Bom dia !

    Estou com um problema parecido.

    Estou usando a versão 2.3.1 e utilizei o pf2ad. Em relação ao Squid tudo funciona normal, inclusive a autenticacão, porém a autenticação pelo AD no Squidguard não funciona. Já tentei várias vezes e nada.

    Alguém tem alguma dica?

    Grato a todos.

    Completando a informação: Se o DC for um Windows 2008 R2 ou Windows 2012 R2 tudo funciona ok porém se o DC for um Samba 4 somente o Squid funciona e o SquidGuard não.

    como você está fazendo essa autenticação no squidguard?

    poste para ver se conseguimos ajudar.

    abraços,

    diego



  • revisei o script no site do pf2ad e realmente acho que ele não instala mais o squidguard… pois nem no site nem no código tem ele escrito

    só no site principal tem uma menção e um vídeo, mas no gitlab nem fala nada...

    enfim, reinstalei novamente, instalei o squidguard denovo e realmente ele não "salva" as configs... mas to achando que o problema é no pacote do squidguard mesmo, e nada a ver com o pf2ad neste caso...

    @andrefreire , qual versão do seu pacote squidguard? ele salva as configs no webconfigurator?



  • Boa noite !

    Didonsom, grato pela ajuda mas resolvi aqui analisando os logs do PFSense.

    Att,



  • Amigos, resolvi.
    O problema era que minha OU tinha C CEDILHA e acento no nome ("Administração").

    Assim, quando eu digitava no campo e mandava salvar, dava algum problema no pfsense e ele dava reload no backup.

    Criei outra OU para testar, sem acentuação e funcionou perfeitamente.
    Esta tudo rodando belezinha como eu queria, a não ser as páginas de erro do squidguard q dão erro de certificado, mas este é outro topico  :P



  • @chipbr:

    Amigos, resolvi.
    O problema era que minha OU tinha C CEDILHA e acento no nome ("Administração").

    Assim, quando eu digitava no campo e mandava salvar, dava algum problema no pfsense e ele dava reload no backup.

    Criei outra OU para testar, sem acentuação e funcionou perfeitamente.
    Esta tudo rodando belezinha como eu queria, a não ser as páginas de erro do squidguard q dão erro de certificado, mas este é outro topico  :P

    Amigo, como ficou sua sintese no "ldapusersearch" ?



  • ldapusersearch ldap://SERVIDORAD.DOMINIO.local:3268/DC=DOMINIO,DC=local?sAMAccountName?sub?(&(sAMAccountName=%s)(memberOf=CN=proxy-liberados%2cCN=Users%2cDC=DOMINIO%2cDC=local))

    essa q eu uso no squidguard para puxar os usuarios do grupo "proxy-liberados"



  • pf2ad nas versões anteriores usavam SquidGuard-dev e na versão do pfsense 2.3 os recursos foram incluídos no SquidGuard, porem, para quem usa pf2ad faz a instalação dos pacotes via repositório do Luiz Gustavo e depois instala o squidguard a parte. Se olharem na lista de aplicativos que o pfsense 2.3 não dá suporte mais está o Squidguard-dev.

    http://forum.mundounix.com.br/viewtopic.php?f=4&t=6&sid=7c7da78531f7f138e08d675fe7fed5b8


Log in to reply