New setup on new SG-4860, 2.3.1-p5, VLAN not sticking on LAN interface



  • I have a new set of rack mount SG-4860s.  They were purchased with the MSATA SSD option.  pfSense 2.3.1-p4 came pre-installed on the MSATA.  The WAN port is currently connected to an internal private network (with internet access).  Via the serial console I upgraded to pfSense 2.3.1-p5.  The igb0 (LAN) interface is connected to a Brocade ICX6450 switch that has not been configured yet, and is powered on.

    I did a "1) Assign Interface" and created 2 x VLANs on igb0:  igb0_vlan128 & igb0_vlan132.  I assigned "LAN" to igb0_vlan128.  I finished creating the VLANs, assigning interfaces & enabled a DHCP range on LAN.  I did a "2) Set interface(s) IP address", with static on WAN & LAN.  I ended up with this:

     WAN (wan)       -> igb1       -> v4: 192.168.169.163/24
     LAN (lan)       -> igb0_vlan128 -> v4: 10.128.0.3/24
     OPT1 (opt1)     -> igb2       -> 
     OPT2 (opt2)     -> igb3       -> 
     OPT3 (opt3)     -> igb4       -> 
     OPT4 (opt4)     -> igb5       -> 
     OPT5 (opt5)     -> igb0_vlan132 -> 
    
    

    I did a reboot, and the interfaces come up as this:

     WAN (wan)       -> igb1       -> v4: 192.168.169.163/24
     LAN (lan)       -> igb0       -> v4: 10.128.0.3/24
     OPT1 (opt1)     -> igb2       -> 
     OPT2 (opt2)     -> igb3       -> 
     OPT3 (opt3)     -> igb4       -> 
     OPT4 (opt4)     -> igb5       -> 
     OPT5 (opt5)     -> igb0_vlan132 -> 
    
    

    After the reboot, 'ifconfig -a' shows:

    igb0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=500bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwfilter,vlan_hwtso>ether 00:08:a2:09:d8:04
            inet6 fe80::208:a2ff:fe09:d804%igb0 prefixlen 64 scopeid 0x1 
            inet 10.128.0.3 netmask 0xffffff00 broadcast 10.128.0.255 
            nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
            status: active
    igb1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:08:a2:09:d8:05
            inet6 fe80::208:a2ff:fe09:d805%igb1 prefixlen 64 scopeid 0x2 
            inet 192.168.169.163 netmask 0xffffff00 broadcast 192.168.169.255 
            inet6 2601:801:4004:6ee3:208:a2ff:fe09:d805 prefixlen 64 autoconf 
            inet6 fd92:4c26:d4b7:1:208:a2ff:fe09:d805 prefixlen 64 detached autoconf 
            nd6 options=net autoselect (1000baseT <full-duplex>)
            status: active
    igb2: flags=8c02 <broadcast,oactive,simplex,multicast>metric 0 mtu 1500
            options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:08:a2:09:d8:00
            nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
            status: active
    igb3: flags=8c02 <broadcast,oactive,simplex,multicast>metric 0 mtu 1500
            options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:08:a2:09:d8:01
            nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
            status: active
    igb4: flags=8c02 <broadcast,oactive,simplex,multicast>metric 0 mtu 1500
            options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:08:a2:09:d8:02
            nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
            status: active
    igb5: flags=8c02 <broadcast,oactive,simplex,multicast>metric 0 mtu 1500
            options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:08:a2:09:d8:03
            nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect
            status: no carrier
    pflog0: flags=100 <promisc>metric 0 mtu 33160
    pfsync0: flags=0<> metric 0 mtu 1500
            syncpeer: 224.0.0.240 maxupd: 128 defer: on
            syncok: 1
    enc0: flags=0<> metric 0 mtu 1536
            nd6 options=21 <performnud,auto_linklocal>lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
            options=600003 <rxcsum,txcsum,rxcsum_ipv6,txcsum_ipv6>inet 127.0.0.1 netmask 0xff000000 
            inet6 ::1 prefixlen 128 
            inet6 fe80::1%lo0 prefixlen 64 scopeid 0xa 
            nd6 options=21 <performnud,auto_linklocal>igb0_vlan128: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            optioet6 fe80::208:a2ff:fe09:d804%igb0_vlan128 prefixlen 64 scopeid 0xb 
            nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
            status: active
            vlan: 128 vlanpcp: 0 parent interface: igb0
    igb0_vlan132: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=3 <rxcsum,txcsum>ether 00:08:a2:09:d8:04
            inet6 fe80::208:a2ff:fe09:d804%igb0_vlan132 prefixlen 64 scopeid 0xc 
            nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
            status: active
            vlan: 132 vlanpcp: 0 parent interface: igb0
    [[/code]
    
    I've tried this three (3) times with the same results.  Am I missing something, or doing something wrong?  I get the same results on the other 4860  I'm going to try without the igb0 (LAN) port connected to the ICX6450 switch.  I'll post an update after that.
    
    Update:  Trying with nothing plugged into igb0 (LAN) made no difference.  I can't get a VLAN to "stick" as the device for "LAN".
    
    Thanks in advance!
    
    Frank</full-duplex></performnud,auto_linklocal></rxcsum,txcsum></up,broadcast,running,simplex,multicast></full-duplex></performnud,auto_linklocal></up,broadcast,running,simplex,multicast></performnud,auto_linklocal></rxcsum,txcsum,rxcsum_ipv6,txcsum_ipv6></up,loopback,running,multicast></performnud,auto_linklocal></promisc></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></broadcast,oactive,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></broadcast,oactive,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></broadcast,oactive,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></broadcast,oactive,simplex,multicast></full-duplex></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></up,broadcast,running,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwfilter,vlan_hwtso></up,broadcast,running,simplex,multicast>
    

  • Rebel Alliance Developer Netgate

    Check the system log before you reboot. From the sound of it, it's rejecting something in the configuration and going back to what it believes is the last valid one. Also check the config history in the GUI (Diag > Backup/Restore, Config History tab) and see what it shows happening.

    Either the configuration change is not being written, or it's being rolled back.