Attached Wireless Router to PFsense but can't see it in ARP Table



  • Today is the first day I have used PFsense and I thought I would try to set up my wireless router with it.  I found the brief instructions at https://doc.pfsense.org/index.php/Use_an_existing_wireless_router_with_pfSense and followed them.

    I went into the router and created a static IP address for the router (I used 192.168.1.2 since I made the leasable range 192.168.1.100… on PFsense setup).  I made PF sense the gateway (192.168.1.1) and also the DNS Server and I used the 255.255.255.0 as the subnet mask.  I also turned of the DHCP.  The wireless router also had a lot of firewall settings, but I wasn't sure if I should turn them off too (should I?).

    Then I restarted the wireless router, hooked up the WAN to my PFsense box, and put connected the LAN on the PFsense box to one of the non-wan ports on the wireless router.  I also hooked one of my computers up to one of the non-wan ports on the wireless router.

    A few minutes later and I had a connection, various wireless devices in my house showed up on the ARP table, and everything seemed to work fine, BUT I can't see the wireless router in the ARP table.  WHERE IS IT?  I tried to log in with the 192.168.1.2 but that didn't work and for extra measure, I tried all the other IP addresses in the table that didn't have Hostnames, just in case.  No luck.

    What am I doing wrong?  How can I see this device in PFsense?  Is my device set up properly or should I change something in the settings?


  • Rebel Alliance Global Moderator

    Sounds like you set the WAN IP of the router and not the LAN IP to me, or you made a mistake in the setting of the IP..

    I would reset the router to default so you can get into.. Then make sure you changing the LAN IP of the router and not setting static on its wan.  Also you can turn off all the firewall features since those only do anything when routing/natting.  Your just using it as AP, so you can turn off all of that stuff and let the wifi router have those spare cpu cycles and ram back for not having that stuff enabled.



  • Thanks.

    OK.  I took all the settings out of the wireless router WAN settings  and was only able to put the 192.168.1.2 in the LAN setting and subnet mask of 255.255.255.0.

    I rebooted everything and I am able to go to 192.168.1.2 now to see the wireless router login, but I still can't find 192.168.1.2 in the ARP table in pfsense.


  • Netgate

    If you are connecting to the AP from another host on 192.168.1.0/24 there is no reason for pfSense to have performed ARP for that address. Go to Diagnostics > Ping and ping 192.168.1.2 then check the ARP table again.

    Your switch would have a mac-address entry for everything on LAN. Your router will not have an ARP entry unless it has been given a reason to perform an ARP.



  • That worked.

    I'm new to PFsense, but I thought that it would have a list of all devices connected to it.  I don't have a switch between Pfsense and the wireless, I'm using the wireless router as the switch.    Would it be better to put a switch in between them or does that not matter?

    Thank you for the help!


  • Netgate

    This has nothing to do with pfSense. This is basic, standard, layer 2/3 stuff for any gear.

    Why do you care so much about what is in the ARP cache? If ARP is properly resolved when it needs to be, don't hassle it!

    Your setup is fine.



  • You have misunderstood how ARP works. It is used only when there is actual traffic on the network. There is no reason to keep an ARP entry dangling if there hasn't been traffic for a while, ethernet is not based on active connections but broadcasts. Because of the broadcast nature of it it's also stateless and it's not possible to (easily) keep track of active or inactive devices on a network.