Mikrotik eksternal proxy Pfsense 2.3.1



  • Salam kenal

    Mohon bantuannya saya sedang membangun Mikrotik dengan proxy eksternal Pfsense 2.3.1
    topologinya

    Internet –--- Mikrotik ----- Pfsense
                            |
                            |
                        Client

    IP Address:
    Mikrotik eth0(tointernet) = 192.168.1.2
                eth1(toPfsense) = 192.168.10.1
                eth5(toClient)    = 192.168.0.1
    Pfsense interface LAN      = 192.168.10.3
    Client                              = 192.168.0.2-200

    di mikrotik
    /ip firewall nat
    add action=masquerade chain=srcnat out-interface=ether1-internet
    add action=dst-nat chain=dstnat comment="transparent proxy" dst-port=80 in-interface=ether5-lan protocol=tcp src-address=!192.168.10.0/24 to-addresses=192.168.10.3 to-ports=3128

    di Pfsense
    squid transparent proxy udah aktif

    permasalahannya:
    kalau di browser client di set manual proxy, maka lancar/jalan
    tapi kalau transparentnya di aktifkan di mikrotik,munculny "INVALID URL"

    he following error was encountered while trying to retrieve the URL: /

    Invalid URL

    Some aspect of the requested URL is incorrect.

    Some possible problems are:

    Missing or incorrect access protocol (should be http:// or similar)

    Missing hostname

    Illegal double-escape in the URL-Path

    Illegal character in hostname; underscores are not allowed.

    solusinya gimana mas?semoga berkenan memberikan solusi dan berbagi ilmu
    terimakasih



  • Salam kenal kembali  ;D

    Dulu kala pernah ngalamin serupa tapi sudah lupa  ;D
    Kita tunggu para rekan pfsense yang masih hidup di dunia ini untuk membalas tread ini yak  ;D
    sekedar info saya lebih prefer mark routing aja timbang nat  ;D

    Salam,
    Agix



  • @fahmisahab:

    Salam kenal

    Mohon bantuannya saya sedang membangun Mikrotik dengan proxy eksternal Pfsense 2.3.1
    topologinya

    Internet –--- Mikrotik ----- Pfsense
                            |
                            |
                        Client

    IP Address:
    Mikrotik eth0(tointernet) = 192.168.1.2
                eth1(toPfsense) = 192.168.10.1
                eth5(toClient)    = 192.168.0.1
    Pfsense interface LAN      = 192.168.10.3
    Client                              = 192.168.0.2-200

    di mikrotik
    /ip firewall nat
    add action=masquerade chain=srcnat out-interface=ether1-internet
    add action=dst-nat chain=dstnat comment="transparent proxy" dst-port=80 in-interface=ether5-lan protocol=tcp src-address=!192.168.10.0/24 to-addresses=192.168.10.3 to-ports=3128

    di Pfsense
    squid transparent proxy udah aktif

    permasalahannya:
    kalau di browser client di set manual proxy, maka lancar/jalan
    tapi kalau transparentnya di aktifkan di mikrotik,munculny "INVALID URL"

    he following error was encountered while trying to retrieve the URL: /

    Invalid URL

    Some aspect of the requested URL is incorrect.

    Some possible problems are:

    Missing or incorrect access protocol (should be http:// or similar)

    Missing hostname

    Illegal double-escape in the URL-Path

    Illegal character in hostname; underscores are not allowed.

    solusinya gimana mas?semoga berkenan memberikan solusi dan berbagi ilmu
    terimakasih

    coba ping google.com dari pf
    bisa connect tidak ?



  • ping google bias pak



  • ternyata bukan saya aja yang ngalaminnya . hmmmm ….. mohon di bantu agan2 disini kamu para newbi perlu bantuan ....
    ini sudah 1 bulan ini belum juga terpecahkan .mohon di bantu semuanya?



  • pfsense tidak bisa dijadikan eksternal proxy, karena squid option bawaan pfsense –disable-linux-netfilter' '--disable-linux-tproxy'



  • Saya coba bantu ya (NAT yang transparan nya coba di disable dulu ya)

    Untuk menjalankan direct (transparent proxy) dari mikrotik ke pfsense saya menggunakan routing di mangle

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="HTTP + HTTPS TO PROXY" dst-port=80,8080,443 new-connection-mark=conn_proxy protocol=tcp src-address=192.168.0.0/24 (IP LAN/CLIENT)

    add chain=prerouting src-mac-address=08:00:27:F7:75:7D (MAC ADDRESS PFSENSE bisa liat di mikrotik menu IP –> ARP)

    add action=mark-routing chain=prerouting connection-mark=conn_proxy new-routing-mark=to_proxy passthrough=no

    /ip route
    add distance=1 gateway=192.168.10.3 (IP PFSENSE) routing-mark=to_proxy

    mangle di atas untuk direct yang HTTPS, kalau hanya ingin HTTP saja tinggal hapus dst-port 443 nya, lalu coba posisikan mangle tersebut di urutan paling atas.

    semoga berhasil  :D