Error on upgrade to 1.2.1-RC1-20080805-0606



  • I upgrade pfsense from 1.2 release to pfSense-Full-Update-1.2.1-RC1-20080805-0606 and after restart I get error "Fatal error: Call to undefined function setup_filter_bridge() in /etc/rc.bootup in line 181". What sould be a problem?



  • My box died i think. I cant access it though webgui anyway. Now i gotto reinstall again.



  • Well, mine is working.
    Version  1.2.1-RC1 built on Tue Aug 5 00:06:33 EDT 2008

    All I'm missing is phpSysInfo which I can live with.



  • pfSense-Full-Update-1.2.1-RC1-20080805-1408.tgz 05-Aug-2008 10:50  38M

    has same error

    box died, no webgui or anything

    reloading it to 1.2.1-RC1 built on Tue Aug 5 00:06:33 EDT 2008



  • I think that you all downloaded images that where having issues.  Please try again with the latest version.

    BTW: setup_filter_bridge() is a 1.3 deal, not 1.2.



  • pfSense-Full-Update-1.2.1-RC1-20080805-1408.tgz 05-Aug-2008 10:50  38M

    just ran the above image and it DOES NOT WORK

    same error as above (the bridge error)



  • last working image as of this post time

    pfSense-Full-Update-1.2.1-RC1-20080805-0406.tgz 05-Aug-2008 00:48  38M



  • that's my bad, I missed a couple lines on a change I made. Try the next snapshot after this message.



  • I upgraded to pfSense-Full-Update-1.2.1-RC1-20080805-1408 and was unable to get to gui or renew an ip to my work station.  The console was able to ping google.com but not internal IPs.  I then did a console upgrade to the pfsense website and reverted back to pfSense-Full-Update-1.2.1-RC1-20080804-2205 and everything is good.



  • same problem, but i fixed it, i tried again using ltest.tgz figuring maybe it was updated but it wasn't, u have to use the latest one from the list


Log in to reply