Unable to install haproxy package on 2.3_1
I upgraded PfSense from 2.2 to 2.3, while updating haproxy, i am getting error message
Updating pfSense-core repository catalogue...
pfSense-core repository is up-to-date.
Updating pfSense repository catalogue...
pfSense repository is up-to-date.
All repositories are up-to-date.
Checking integrity... done (0 conflicting)
The following 3 package(s) will be affected (of 0 checked):
New packages to be INSTALLED:
pfSense-pkg-haproxy-devel: 0.47 [pfSense]
haproxy-devel: 1.7.d2 [pfSense]
lua53: 5.3.2_1 [pfSense]
The process will require 3 MiB more space.
[1/3] Installing lua53-5.3.2_1…
[1/3] Extracting lua53-5.3.2_1: …....... done
[2/3] Installing haproxy-devel-1.7.d2…
[2/3] Extracting haproxy-devel-1.7.d2: …..... done
[3/3] Installing pfSense-pkg-haproxy-devel-0.47…
[3/3] Extracting pfSense-pkg-haproxy-devel-0.47: …....... done
Saving updated package information...
Loading package configuration... done.
Configuring package components...
Loading package instructions...
Executing custom_php_install_command()...pkg: POST-INSTALL script failed
Cleaning up cache... done.
I followed http://blog.stordata.se/index.php/2016/04/13/upgrade-to-pfsense-2-3-breaks-haproxy-how-to-do-it/
but no luck.
Any suggestions except reinstalling pfsence with new version
Have you tried removing all old files?: https://forum.pfsense.org/index.php?topic=109783.msg611641#msg611641
Though this supposedly was fixed in pfSense bas upgrade to uninstall old files first automatically..
Only fixed if you upgraded 2.2.x or earlier to 2.3.1, that's on 2.3.0_1.
First upgrade to 2.3.1_5, then try again.
Ah yes your right, i 'read' 2.3.1 if kulpreet is still on 2.3.0_1 that explains it.
@kulpreet , can you confirm that 2.3_1 is the version your running and not 2.3.1 ?
Upgrading pfsense and/or deleting old files as mentioned above should fix this issue. If your still having trouble getting it to run let us know :).