Noob install question



  • Hi all!! Having seen PF Sense talked about all over the YT channels I follow I thought I would check it out.

    I downloaded the AMD64 USB Memstick Installer VGA image (I have also tried the serial option) . When I boot from the USB I don't get an install option as per the install guide (https://doc.pfsense.org/index.php/Installing_pfSense). Instead I get a page with 6 selections:

    1. Boot Multi User [Enter]
    2. Boot ~~ingle User
    3. [Esc]ape to loader prompt
    4. Reboot

    Options:
    5. [K]ernel: kernel (1 of 2)
    6. Configure Boot [O]ptions…

    Where would I find the actual install image?~~


  • LAYER 8 Netgate

    You have to let it boot. Just press Enter there.



  • Still no potion to install.

    I get a message:

    Fatal trap 12: page fault while in kernel mode

    a bunch of text then

    Stopped at igb_detach+0x1f: cmpq $0,0x78(%r15)


  • LAYER 8 Global Moderator

    Maybe some help on what your trying to install it too exactly..



  • Gigabyte B150M-D3H MB with an i3-6320 CPU. NIC is a dual port Intel PRO card (EXPI9402PTBLK)



  • That system function with other OSes? A failure that early in the boot process seems likely to be a hardware issue. Is it a known-legit NIC? Some of the Intel cards from questionable sources are knock offs that don't actually work correctly. Might not be related to the NIC at all, but igb_detach is part of the Intel NIC driver.



  • Yes it works with Windows 10 fine. The card is a genuine Intel NIC, $256 worth from an Australian PC store.



  • Sounds like that rules out the NIC, should be a legit source. Lot of people buy cheap questionably sourced hardware here is why I asked.

    Next I'd suggest the usual routine when there is some kind of weird hardware incompatibility. First, make sure you're on the latest BIOS version. Later revisions often fix weird bugs that don't exhibit themselves on Windows (or it never would have passed QA initially), but pose an issue with some other OSes.

    If that doesn't help, try resetting the BIOS to its default settings. Seems like that's probably a newish board so may already be at defaults, but still worth a shot. After doing that, I'd disable the onboard sound card. It's possible, if not likely, it's the cause of the issue.

    If that all fails, try installing with as much hardware removed as possible. Might just be the NIC that you can take out, but that's at least worth a shot to know whether or not it installs without the additional card.



  • Solved problem awhile back. Something wrong with the bios. I put the card into a windows machine, updated the bios and now it works fine.


Log in to reply