Remote Desktop From Out Problem



  • Hi my dears, I have Problem with remote desktop from Internet to local client ..
    I already setup pfsense on my lan like the structure in the following image

    The internet work well on client with activeportal..
    I already have dyndns account and the client of dyndns work in the client computer perfectly..
    Before setup pfsense I was make portforward for client 192.168.1.33 on port 3389 on the ISP Modem and it was working perfectly …
    (Lan Config for the ISP Modem was 192.168.1.1  255.255.248.0)
    After Change it to 172.16.1.1 255.240.0.0
    When I try to portfoward  the same client (192.168.1.33) because it isn't in the same range of modem ip

    My Config:
    WAN Interface

    Nat Config:

    Firewall Rule on WAN:

    Firewall Rules on LAN:

    Activeportal:

    That's all my config …
    Then How to solve the problem ???
    Thanks in advance



  • So on your ISP modem forward RDP to pfSense WAN now > 172.16.1.2, instead the hosts LAN address.



  • @viragomann:

    So on your ISP modem forward RDP to pfSense WAN now > 172.16.1.2, instead the hosts LAN address.

    Thank you my drea friend (viragomann)

    I did but still the problem, does it need any other configuration on pfsense, if yes, then whats?

    Thanks in advance



  • In "Nat Config:" you have 192.168.1.33 in Destination IP, and this is wrong configuration.
    You should select your WAN address there.
    (because "destination ip" is there original packet should be RECEIVED by pfsense)



  • @pan_2:

    In "Nat Config:" you have 192.168.1.33 in Destination IP, and this is wrong configuration.
    You should select your WAN address there.
    (because "destination ip" is there original packet should be RECEIVED by pfsense)

    Thank you (pan_2) and (viragomann) for your help, that works fine for me …..



  • Hello my dears (pan_2) and (viragomann) and anybody can help me,
    I Success in config remote desktop, but when i do the same thing for the dvr which have ip 192.168.1.64 Server Port 8000 not work when i try to connect to it from the internet
    I use the following website to check open ports when i check 3389 it tell it is (Open) but when i check port 8000 it tell is is (Closed)
    http://www.yougetsignal.com/tools/open-ports/

    Thanks in advance …



  • You ISP can block it, as ''well-known web hosting port''
    Change to some other one on your modem.



  • Thank you (pan_2) i solve it by put the DVR ip address in (allowed ip address) in (Captive Portal) …