Unable to enter IPv6 address in NPT rules on firewall_nat_npt_edit.php



  • Hello everyone, So I've got myself a multi homed situation I'm trying to sort out.
    I have had a /48 address allocated to me from Hurricane Electric "HE/48"
    I have a /60 provided by ISP1 "ISP1/60"
    And i have a /48 provided by ISP2 "ISP2/48"
    So i'm trying to figure out my NPT rules for this. I've already assigned the "HE/48" internally and i've been able to get the "ISP2/48" setup with NPT working.
    But i haven't been able to enter a rule for the /60 in the NPT page.

    I'm getting a "Please match the requested format" error from the webpage similar to https://forum.pfsense.org/index.php?topic=107491.0
    I've tried adjusting all the rules to have a /60 subnet mapping since that seems more sane but I still get the "Please match the requested format"
    Tested with 2.3.1-RELEASE-p5



  • Getting "Please match the requested format" means you're not inputting a valid IPv6 subnet. It needs to end with :: and otherwise be a valid IPv6 subnet.



  • I've tried that.
    Example: 2001:B470:3051:E010::
    Select /60
    "Please match the requested format"



  • Use lower-case letters.

    Technically IPv6 is case-insensitive, but RFC specifies they must be in lower case.
    https://tools.ietf.org/html/rfc5952#section-4.3



  • For improved usability I would suggest noting that either in the description or error message that pops up.