Install/Boot issue with Samsung 950Pro NVMe M.2 drive in x4 slot



  • Temporarily running pfSense 2.3.1 on SATADom as i'm having issues getting the NVMe SSD to complete the installation and boot.

    SM X10SDV-TLN4F with 32GB Crucial DDR4 2400 Ram
    Samsung 950Pro NVMe 256GB M.2 in x4

    Both custom and easy install give the following error:

    Installation Screen:
    Cancelled
    Execution of the command
    /sbin/dumpon -v /dev/nvd0s1b
    FAILED with a return code of 71

    Log entry:
    Executing `/sbin/dumpon -v /dev/nvd0s1b
    | dumpon: ioctl(DIOCSKERNALDUMP): Operation not supported by device
    Exit status: 71

    If I skip that step and continue with the install, after rebooting I get the following screen:

    F1 pfSense

    F6 PXE
    Boot: F1

    However it appears to hang here and nothing works: F1, F6, space or enter

    Any ideas on how to get the NVMe drive to work with pfSense would be appreciated, thanks.



  • Update:  Original install was in dual boot mode (Legacy/UEFI) bios version 1.0c with x4 slot set to legacy mode which apparently Samsung supports for the 950 Pro.

    After reading up on others attempts booting from NVMe on this MB for windows machines using GPT format vs MBR, I tried installing pfSense from USB in UEFI mode with x4 slot set to EFI.  No luck, won't recognize the pfSense usb boot file or the NVMe drive upon startup unless I am doing something wrong here.

    Tried installing with CSM turned off and that didn't work either.

    Haven't figured out if the sbin/dumpon executable error has anything to do with the failed boot, is this a kernel dump?

    Haven't seen a reason to update the bios to 1.1a as it seems to be the same as 1.0c which came on the Rev. 2 board.



  • I have exactly the same problem

    /sbin/dumpon -v /dev/nvd0s1b
    FAILED with a return code of 71

    dumpon: ioctl(DIOCSKERNALDUMP): Operation not supported by device

    I can not go the next step and stays forever here

    F1 pfSense

    F6 PXE
    Boot: F1

    will have some trick? or is it that with so much hardware is incompatible still after so long
    pfsense support, can look a little this high-end storage please.

    YES: update bios, new version of pfsense, installing with MBR, UEFI, Legacy & nothing happens.


    pfSense 2.3.2
    X11SSH-LN4F
    Supermicro 32GB DDR4 2133 mhz
    950 PRO m.2 512GB

    ![cancelled nvd0s1b.png](/public/imported_attachments/1/cancelled nvd0s1b.png)
    ![cancelled nvd0s1b.png_thumb](/public/imported_attachments/1/cancelled nvd0s1b.png_thumb)
    ![bsd installer 01.png](/public/imported_attachments/1/bsd installer 01.png)
    ![bsd installer 01.png_thumb](/public/imported_attachments/1/bsd installer 01.png_thumb)
    ![bsd installer 02.png](/public/imported_attachments/1/bsd installer 02.png)
    ![bsd installer 02.png_thumb](/public/imported_attachments/1/bsd installer 02.png_thumb)
    ![F1 pfSense.png](/public/imported_attachments/1/F1 pfSense.png)
    ![F1 pfSense.png_thumb](/public/imported_attachments/1/F1 pfSense.png_thumb)



  • EDIT: 2.4 snapshot works out of the box

    –-

    @Sxecurity How did you solve the issue (your signature implies that you got it working :) )?

    2.3.3-RELEASE easy install fails immediately

    2.3.3-RELEASE custom install

    • is able to see NVMe disk (nvd0)

    • format it

    • base partition it (FreeBSD type selected)

    • install bootblock

    but it fails on subpartitioning with the same error

    
    /sbin/dumpon -v /dev/nvd0s1b
    FAILED with a return code of 71
    
    


  • You realize you are installing pfSense on a NVMe drive right? That's like pulling a tractor trailer with a Yugo, you can do it but why would spend good money on something that would never benefit from it's true performance?

    I put an SSD in my Firebox thinking it would be 100 times faster, but in the end it was no faster than the modern day SATA 2.5" HDD.



  • offt:

    @Smoothrunnings yes.

    • do you realise that price argument has been heard multiple times?
    • are you informed on current NVMe prices (i bought SM961 for 90 EUR + VAT)?
    • do you realise i could save some euros if going M2 SATA (starting 50 EUR, those below (Transcend brand) are super slow and have heating issues)?
    • why should i choose M2 SATA over M2 NVMe is more energy efficient?
    • do you realise that having M2 means that the only cables in the system are power, one can use whatever case?
    • not entirely good argument, but if someone considers NVMe he/she is most probably putting a totally new system with new mobo, that has much more costs than just refitting existing system - and NVMe price overhead is negligible in the total. why not invest in future?
    • something that would never benefit is hasty generalisation - having cacheing and 10 GbE LAN should benefit.

    sorry to reply in same bit sarcastic form, i know you meant it to illustrate your point and so do i ;) but really, price is not strong argument any more (in context of new system). one gains energy efficiency and no cables (so much more freedom for enclosure).



  • Not to mention the fact that a device with NVMe drive could always be repurposed for a more intensive task without replacing hardware. I don't see any issues with it.

    I have the same drive and I also get the same error. I just choose "Skip" and it continues with the installation properly.