Not getting second public IP from cable modem



  • My cable modem will assign up to 2 IP when it is hooked up to a unmanaged switch. Both my pfSense boxes will each get a different wan IP. This also works with a home router that supports vlan. I use 3 ports on one vlan for cable modem, pfSense 1 and pfSense 2.

    Now I have a Cisco SG200-26 managed switch, created a access mode vlan with 3 untagged ports for cable modem, pfSense 1 and pfSense 2.  With this configuration, only pfSense 1 will get an IP. pfSense 2 only shows a gateway after a long delay but no IP. This occurs even after I release the IPs from the wan interfaces, reset my cable modem and do a DHCP renew. Any ideas?



  • If you put unmanaged switch between your modem and pf1/2 and all is working,  then the problem is your cisco managed switch, I think.
    Check also that you have latest cisco firmware and that ports mode is "trunk" — move it to "general", apply and move then back to "trunk", apply, for sure.



  • Cisco firmware 1.4.5.02 loaded. Was not sure the update was cumulative so I flash all the incremental updates. Did not find a more recent boot version than 1.3.5.06 so I guess it is up to date.

    I did try vlan in trunk mode with the move to General step and apply. No change in results.

    Finally, I turned off globally STP and all the Discovery options. Success!

    I will go back and play with the settings at the interface level to determine exactly what needs to be turned off.

    Thank you for your help.