Can't access 192.168.1.1 pfSense page with browser



  • I installed pfSense on an extra computer and it seems to be working.  I am getting through to the web with my main computer through it.  When I first connected, I was able to go to 192.168.1.1 and got to the first page.  I then made the mistake of putting 127.0.0.1 into the Primary DNS Server line and un-checking the Override DNS box below the line.  This mistake seems to have made it impossible for my browser to get to the pfSense pages again to make setup changes (getting ERROR The requested URL could not be retrieved).  Does anyone know if I could go into the server via edit or nano and make corrections to whatever I have messed up?  Possibly this could all be corrected if I make LAN DHCP4.  Thanks.
    `Some parameters I looked at:

    WAN = em1 v4/DHCP4: my.isp.?.?/22
    LAN = em0 v4: 192.168.1.1/24

    resolv.conf = nameserver 127.0.0.1
    hosts = 127.0.0.1 lockhost localhost.localdomain
                  192.168.1.1 pfsense localhost pfSense`



  • Log into the console or via SSH and select "15)  Restor recent configuration" from the menu.



  • Tried it but nothing changes.  As you can see below with pfTop, 192.168.1.1 is being accessed via the terminal on port 22.  But even if I disable sshd, it still doesn't connect to pdSense with the browser.  I also tried installing the latest version 2.3.1 this morning, but nothing.  Tried 192.168.1.1:80, tried changing to 192.168.1.2.

    PR      DIR SRC                                DEST                          STATE tcp      In  192.168.1.100:50121      192.168.1.1:22          ESTABLISHED:ESTABLISHED



  • Just to help me understand your post: you're blackmailing this forum with "I may have to go to ipfire" if the community of volunteers doesn't help you quick enough? Smart move…

    If you can SSH into pfSense do you see the console menu?

     0) Logout (SSH only)                  9) pfTop
     1) Assign Interfaces                 10) Filter Logs
     2) Set interface(s) IP address       11) Restart webConfigurator
     3) Reset webConfigurator password    12) pfSense Developer Shell
     4) Reset to factory defaults         13) Upgrade from console
     5) Reboot system                     14) Disable Secure Shell (sshd)
     6) Halt system                       15) Restore recent configuration
     7) Ping host                         16) Restart PHP-FPM
     8] Shell
    
    Enter an option:
    

    Try option 16) first.
    If that's not successful then use option 4).



  • I must apologize!  I was just so frustrated after trying bunches of things all day, I spoke inappropriately.  I have also had trouble lately getting answers from a network forum that kept refusing my network questions because of the forum's intolerance for nooby questions.  I didn't mean it as a slight against pfSense, just what I was thinking of doing.  The post has been modified.
    Yes, I have the console window.  I have tried 4, but I'll try 16 now.
    Thanks.



  • Probably not an issue in this scenario, but it might be worth trying with a different browser.
    I've had one or two GUI access issues in the past that ended up being resolved with a change in browser.
    My two go-to products are Firefox and Chrome.

    Pretty simple, - worth a try to eliminate one more variable.



  • @battles:

    I have tried 4, but I'll try 16 now.

    Huh?
    Reset to factory defaults did not help?
    Have you tried clearing your browser's cache (or simply use another browser as divsys proposed)?

    Your problem is somewhere else if you cannot connect after a full reset.



  • Yes, I tried firefox and IE.  That is all I have.  Cleared cache.

    "Your problem is somewhere else if you cannot connect after a full reset."

    I think you might be correct.  It may something with my machine.  Here is the ipconfig.  Maybe you can see some problem here:

    `c:>ipconfig

    Windows IP Configuration

    Ethernet adapter Local Area Connection 2:

    Connection-specific DNS Suffix  . :
      Link-local IPv6 Address . . . . . : fe80::9474:2104:2b7e:6f54%16
      Autoconfiguration IPv4 Address. . : 169.254.111.84
      Subnet Mask . . . . . . . . . . . : 255.255.0.0
      Default Gateway . . . . . . . . . :

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix  . :
      Link-local IPv6 Address . . . . . : fe80::d5bc:1d04:c0ae:7ea3%11
      IPv4 Address. . . . . . . . . . . : me.me.me.9
      Subnet Mask . . . . . . . . . . . : 255.255.252.0
      Default Gateway . . . . . . . . . : me.me.me.1

    Ethernet adapter VirtualBox Host-Only Network:

    Connection-specific DNS Suffix  . :
      Link-local IPv6 Address . . . . . : fe80::1597:c07:deff:3202%15
      IPv4 Address. . . . . . . . . . . : 192.168.56.1
      Subnet Mask . . . . . . . . . . . : 255.255.255.0
      Default Gateway . . . . . . . . . :

    Tunnel adapter isatap.{F0FE9EAC-AF25-464C-95A8-10A9C68D5A14}:

    Media State . . . . . . . . . . . : Media disconnected
      Connection-specific DNS Suffix  . :

    Tunnel adapter isatap.{0C2A0069-CA31-4959-99D1-7C3C0E3783E2}:

    Media State . . . . . . . . . . . : Media disconnected
      Connection-specific DNS Suffix  . :

    Tunnel adapter 6TO4 Adapter:

    Connection-specific DNS Suffix  . :
      IPv6 Address. . . . . . . . . . . : 2002:321a:ea09::321a:ea09
      Default Gateway . . . . . . . . . : 2002:c058:6301::1

    Tunnel adapter isatap.{7D179DE7-042B-4349-8FE1-22BDCAFFCA61}:

    Media State . . . . . . . . . . . : Media disconnected
      Connection-specific DNS Suffix  . :

    c:>`



  • Do you get an IP from DHCP on your LAN1 connection or is it configured statically?
    Where is LAN2 connected to (self-assigns an APIPA IP)? Disconnect what's not needed for clarity.



  • @jahonix:

    Do you get an IP from DHCP on your LAN1 connection or is it configured statically?
    Where is LAN2 connected to (self-assigns an APIPA IP)? Disconnect what's not needed for clarity.

    I only have one WAN and one LAN.  The LAN is static.  I tried replying to make it a DHCP once when asked, But I couldn't tell anything.  It just said
    v4:192.168.1.1/24.  I thought it would say v4/DHCP4:192.168.1.1/24.



  • Well, I'm in!  divsys had the answer.  I downloaded the Midori Portable browser and it connected.  Firefox and IE wouldn't.  Thanks very much for all your help and suggestions.
    I will probably be back.  I am thinking about installing snort.  I am not sure what pfsense does just by itself.



  • @battles:

    I am not sure what pfsense does just by itself.

    You were referring to Ipfire earlier. What would that do for you?
    Pretty much all of that does pfSense plus a ton of other things (but I haven't looked at Ipfire for a long time).



  • I think pfSense is superior to ipfire.  The only reason I was considering it was because I couldn't get into pfSense, until I tried another browser.  Ipfire is also 64bit only, so that wouldn't work anyway on my 32bit controller.



  • The issue you face is most likely due a proxy somewhere on your network and your browsers obtain those settings automatically. You should edit the appropriate browser settings. Most of the times the other browsers pick the default settings from Internet Explorer (Windows).


Log in to reply