NAT não funciona após atualização para 2.3



  • Bom dia Senhores,

    Sempre usei o proxy transparente, fazendo um nat pelo firewall do pfsense.
    Agora para minha surpresa, após atualização para versão 2.3, o NAT não está funcionando de maneira nenhuma.
    Pesquisei bastante, mas não encontrei solução para esse problema.
    A solução de contorno que estou usando, é deixar o squid interceptar a conexão http.
    Segue em anexo a minha configuração.

    Desde já agradeço pela ajuda.




  • tambem estou com este problema. So funciona o NAT para o  MS Rdp. Mesmo duplicando a regra do MS-RDP e so alterando as portas não funciona. Voce chegou a testar se a porta está aberta (http://www.gwebtools.com.br/scanner-porta)? Para mim a 3389-> aberta e 80-fechada, recebo o ip publico direto na interface wan.










  • Galera, boa tarde.
    Sou novo aqui no fórum, estou no início dos estudos sobre pfSense, mas já tenho experiência anterior com outros firewalls…

    Instalei a ultima versão - 2.3.2-RELEASE (amd64) e consigo acessar externamente GUI do pfSense na porta 443 pela NAT que fiz... até aí tudo certo. Porém ao tentar configurar um acesso via TS (3389) em uma máquina não vai de jeito nenhum... Tanto na porta nativa 3389 quanto redirecionando para qualquer outra...

    Chego a ver o pacote por meio do monitor de pacotes mas nao vai... Do pfSense para o computador em questão ele enxerga a 3389 aberta; testei localmente o acesso ts e funcionou, porém de fora da rede nada...

    Bom, se alguém conseguir a solução ou eu puder contribuir para com os demais, estarei à disposição



  • Cairo, tentou abrir outra porta? ftp por exemplo? aqui eu nao consigo abrir nenhuma outra alem da 3389, sendo que esta foi o primeiro nat que fiz.



  • Tentei sim… eu consigo acesso externo pela 443 ao firewall. Mas na 3389 ou qualquer porta redirecionando para a 3389 no NAT, não :(



  • Prezado Bruno,

    A minha versão do PF é 2.3.
    Consigo utilizar o DNAT normalmente. Tenho 3 links de dados. Utilizo apenas o WAN3 para receber as conexões.
    Ja utilizei o DNAT para outras portas (80 e ftp), mas no momento, utilizo apenas para o RDP 3389.
    No caso, eu utilizo o IP/porta IP:60010, para se conectar quando estiver fora da rede interna.
    Lembrando que, se for modem ADSL, o mesmo tem que estar em modo BRIDGE, para que o PF faça o PPOE e receba o IP WAN na interface correspondente.
    Minhas configurações estão assim:

    Interface: WAN3
    Protocolo: TCP/UDP
    Destination: WAN3 address
    Destination port range: From port: Other,  Custom: 60010, To port: Other, Custom: 60010
    Redirect target IP: O ip do host interno no qual vai receber a conexão
    Redirect target port: MS RDP

    Veja se funciona.



  • Prezados,
    Agradeço ao retorno, principalmente do gilberto.lps, porém consegui fazer a configuração correta.
    Creio que foi um erro de principiante ::) mas agora já está funcionando a abertura e redirecionamento de portas como eu precisava.

    Desejo a todos bons estudos e evolução do conhecimento!
    :)



  • Blz Cairo. tbm consegui aqui. o problema era o seguinte: minha operadora nao permite que eu acesse as configs do roteador. antes de implantar o pfsense, o roteador deles era responsavel por tudo ,dhcp, roteamento etc.. e havia umas regras de nat nele. quando colocamos o pfsense para rodar solicitamos ao provedor que colocasse o roteador em bridge, mas esquecemos de apagar as regras de nat. por algum motivo que desconheço essa regras estavam infulenciando, só foi apagar que deu certo.



  • Estou com o mesmo problema sem conseguir poderiam me auxiliar?