Upgrade from 2.3.1_1 to 2.3.1_5 fails on ESXi



  • I am currently running two PfSense in a vitualized environment. I'm trying to upgrade to 2.3.1_5 but every time i try, i get errors about bad blocks. This does not make much sense since this is virtualized and there are no known bad drives.

    So here is how it is happening:
    1. install update thought GUI or CLI (completes successfully)
    2. See lots of errors running through the console
    3. PfSense crashes and reboots
    4. PfSense will not boot because there is no /boot/kernel/kernel

    (See images attached)

    I've tried to reboot prior to upgrading to make sure it was working properly.
    I have a snapshot of before the upgrade so i can revert back easily.

    Did anyone encounter this issue before?
    ![1-upgrade in progress.png](/public/imported_attachments/1/1-upgrade in progress.png)
    ![1-upgrade in progress.png_thumb](/public/imported_attachments/1/1-upgrade in progress.png_thumb)
    ![2-bad blocks.png](/public/imported_attachments/1/2-bad blocks.png)
    ![2-bad blocks.png_thumb](/public/imported_attachments/1/2-bad blocks.png_thumb)
    ![4-boot error.png](/public/imported_attachments/1/4-boot error.png)
    ![4-boot error.png_thumb](/public/imported_attachments/1/4-boot error.png_thumb)


  • Rebel Alliance Developer Netgate

    Looks like it lost contact with the disk or it received errors from the disk. That most likely is not a pfSense problem but a storage issue in vmware.


Log in to reply