Prevent IPv6 tunnel interface from starting automatically at boot.



  • I set up an IPv6 tunnel using Hurricane Electric. However, I only need it sporadically and want to disable it most of the time. But even if it's disabled in the web GUI before the system gets shut down it still gets enabled upon next boot.

    After boot, the web GUI still reports the interface as disabled:

    However, when I log in through SSH and run "ifconfig" it shows the interface is actually enabled:

    When I go to http://test-ipv6.com/, I get a 10/10 on the test, which further confirms the interface is enabled.

    Is this a bug or intended behavior? Is there any way to prevent the interface from getting enabled at boot?


  • Rebel Alliance Developer Netgate

    The interface assignment for that is just a stub, really. Disabling that doesn't stop it from being configured. The actual config for the interface is in the GIF settings under Interfaces > (assign), GIF tab.


Log in to reply