TRIM on SG2220



  • Hello, I recently purchased a few SG2220's, with the mSATA ssd installed and to my surprise, trim was not enabled. I know how to go in to single user mode and do it, any reason this would not be on by default for this hardware that came with an ssd? Should I even worry?



  • You should ask the pfSense shop team and/or support if that mSATA is TRIM compatible or if only
    their install script will be forgetting that.



  • We discovered a problem with the installer not enabling TRIM in that case this week.

    You can enable it manually by booting the system into single user mode, and running:

    tunefs -t /dev/da1s1a
    

    Though double check what your root partition actually is, I don't recall for sure off the top of my head what the M.2 shows up as in that case. 'dmesg |grep da0', then da1, etc. as needed to find it.



  • I rebooted my 2440 to single user mode, Option 2 and used this set of commands to check the trim status, enable trim and verify trim was set:

    tunefs -p /
    
    tunefs -t enable /
    
    tunefs -p /
    

    Issue a reboot command and get a shell, Option 8, and use the "tunefs -p /" to see that your change survived the reboot.



  • Ah yeah, thanks Stan, forgot it takes just / there as well. That's easier.


Log in to reply