100% CPU load on standard host MIB SNMP



  • I've upgraded 2 1.2 installations to pfSense-Full-Update-1.2.1-RC1-20080806-1907.tgz today.
    We use cacti(www.cacti.org) to monitor our network devices, and after the upgrade both upgraded pfSenses show constant 100% CPU load on the standard host MIB(oid .1.3.6.1.2.1.25.3.3.1) although this is not really the case(RRD graphs inside the pfSense webinterface show the correct values, as does "top" from the commandline). Other SNMP data(such as PF statistics and interface traffic) shows correctly, so it's not a general SNMP problem.

    I think this is a bug, havent tried a fresh 1.2.1 install though.



  • Hi,

    same here… Has anyone find a solution?

    Thanks and regards



  • I cannot help with the initial problem but found the link to cacti being slightly incorrect.
    You can find it here:  http://www.cacti.net

    Once I have some spare time I will have a deeper look at cact and might implement it on my site as well. Sounds useful!



  • It seems to be a known problem.

    I'm not a kernel/snmp expert but I found this thread :

    http://unix.derkeiler.com/Mailing-Lists/FreeBSD/current/2008-05/msg00436.html

    So it's not a Cacti problem.

    On my Alix 2c3, the command :
    %snmpwalk -v2c -c public XXX.XXX.XXX.XXX hrProcessorLoad
    returns me :
    HOST-RESOURCES-MIB::hrProcessorLoad.4 = INTEGER: 100

    Regards



  • Thanks, fix just commited. Please try next snapshot run.



  • Just did a upgrade to pfSense-Full-Update-1.2.1-RC1-20080814-1819.tgz(but maybe the fix is not in this snapshot, will try again later), but the problem still exists.

    snmpwalk -v2c -c public XXX.XXX.XXX.XXX hrProcessorLoad returns
    HOST-RESOURCES-MIB::hrProcessorLoad.7 = INTEGER: 100

    On 1.2.0 stable it returns the correct values.



  • Still not solved in pfSense-Full-Update-1.2.1-RC1-20080815-2044.tgz .



  • That patch is there, guess that was not the resolution after all.



  • Correction…it does seem to work now in pfSense-Full-Update-1.2.1-RC1-20080815-2044.tgz after an extra reboot.
    CPU loads seems to be somewhat lower then before the upgrade to 1.2.1, probably the same thing as mentioned in luma's link.
    But this is much better, thanks!




  • Good work! Yes it's now working with the new update or reboot, I don't really know! Thanks for your good work!

    Regards


Log in to reply