Just started using PFsense and Plex server cant see through



  • Hello all, I decided to add to my "collection" in my server cabinet by adding a PFsense box along with my Unraid box (Plex, Sickbeard, SABNZBD).

    I'm using a Nanobsd (4g) version 2.3.1-Release-p5(amd64). I've kept to teksyndicates install of pfsense besides using PPPOE for my WAN to my ISP. So mainly default options. The issue i'm having is that I cannot access my Plex server anywhere besides if I launch the GUI from my Unraid GUI. I tried adding a NAT Port forward and Firewall rule for the manually assigned port of 32400 like many others had. I ensured that Plex was manually set to this as well and I'm having no luck.

    I've been fighting with this for 2 days now…Otherwise thats the only thing that is being blocked and everything is working great...



  • This is more of plex support than pfsense, mine works fine with pfsense.  You can manually set the port for plex, if plex can't use the default port, it will go looking for another.  My suggestion would be to manually assign the port, make sure to create the rules.

    You could also enable UPNP, not a wise idea as UPNP is not very secure, but you could see if it will connect that way, then go into pfsense, under status you will see at the bottom, UPNP/NAT UPNP and it will show the ports in use.  You will see two ports in use if using UPNP, not that it will tell you much, but you will get an idea if it is working or not.

    More than likely, your rules are wrong, and I presume plex has a static IP?  would be nice to see the rule you created for plex, this way we have an idea of how you're trying to get it to work.



  • Have you seen this?

    https://support.plex.tv/hc/en-us/articles/206225077-How-to-Use-Secure-Server-Connections

    Look for the rebind issues as well. Not necessarily your problem but it hit me with pfsense… :-)



  • i may not know what the hell i am doing but, i found my pfblocker causes problems with my plex. specifically, the europe block rules. apparently, plex does some authentication using servers there. check your firewall logs for ip's that resolve to eu-west-1.compute.amazonaws.com. i always have to pass those through for my remote plex to work when using pfblocker.


  • Rebel Alliance Global Moderator

    I just vpn in…  Much simpler and more secure than opening up a port to public internet.



  • Well, with Plex adding more and more capability (like Sonos access), and the ability to share servers among family members and/or friends, VPN may not be an option for some.

    BTW, with their Sonos integration that appeared yesterday, I found the need to enable NAT Reflection for my Plex port forward. The NAT+Proxy mode needed to be selected; pure NAT did not work. This allowed my Sonos system within my network to be able to access my Plex server (also within my network), and also allowed the external web-based Plex client to function as well (which I don't really need to use while I'm on my home network, but it did make things work a lot smoother). I'm guessing that Plex's "directory" system tracks servers using the external IP address, which would make sense for mobile devices while on the go… but I'm surprised that they don't also note the internal IP address for when you're on-network.

    So if the OP hasn't tried enabling NAT Reflection (NAT + Proxy) on the NAT rule for Plex, that might make things a whole lot better for using Plex while at home. :)