Allowing inbound ftp



  • Aim running a small ftp server for personal use but I can't get it trough pfsense. I tried searching the wiki page for some help but couldn’t find my answer

    What have I done so far
    ftphelper enabled
    Forward port 21-22 to my server

    running pfsense 1.2-RC2

    Any help is appreciated



  • First: update to 1.2 release

    Did you read this: http://devwiki.pfsense.org/FTPTroubleShooting ?



  • First off, FTP will only work on the primary WAN until someone finishes pftpx-routeto integration. It is also NOT currently working in load balancing situations

    So aim ****** (aim using a dual wan setup)

    guess ill need to set up a sftp server

    thanks for the help



  • What i would do:

    1: Disable the ftp-helper on all interfaces.
    2: Define a port-range on your ftp-server for the data-transfer.
    3: forward port 21 and your data-transfer-range to your server. You can do that for each WAN.

    After this you should now be able to access your server from both WANs.
    –> A friend is running his ftp-server like this right now.


Log in to reply