Vm_fault pager read error pid 1 (init) while reboot



  • I try to install pfsense amd64.iso to vm.  but throw  "vm_fault pager read error pid 1 (init)" while reboot

    I following steps:

    1. Download amd64bit  https://www.pfsense.org/download/
        2. extract it download a file.
        3. add to virtual box 
          add net work  1. briged  2. internal net work.
        4. flow this tutorials https://doc.pfsense.org/index.php/Installing_pfSense

    followhte tutorials system says to reboot while install , i remove my disk and reboot, then throw this error "vm_fault pager read error pid 1 (init)".

    Why throw this problem while Reboot? is there any problem?

    Then, i shutdown and start  now show last page of  this tutorials https://doc.pfsense.org/index.php/Installing_pfSense

    then get WAN  addr to ping to local maching its not working  for me?  Suggest me how to solve this problem, but local machine ipaddr ping  within pfsense vm .

    Suggest me What is the problem?  How to solve this?



  • You should post information about the hardware where you're running pfSense (Motherboard, CPU, RAM, HDD…).

    I'd test RAM (Memtest86) and HDD (Check SMART info) to exclude any hardware defects.



  • please find information about my pc.  this link http://pastebin.com/pZT1gAxK    AND    http://pastebin.com/XPyqagdC


  • Rebel Alliance Developer Netgate

    You mentioned using VirtualBox, what are the exact VM configuration parameters?



  • Hmm. VirtualBox…

    FreeBSD/i386 10.3-RELEASE running as a guest operating system on VirtualBox can have a problem with disk I/O access. It depends on some specific hardware configuration and does not depend on a specific version of VirtualBox or host operating system.

    It has been reported that instability may be present on virtual machines running on other hypervisors, such as Xen or KVM.

    It causes various errors and makes FreeBSD quite unstable. Although the cause is still unclear, disabling unmapped I/O works as a workaround. To disable it, choose Escape to loader prompt in the boot menu and enter the following lines from loader(8) prompt, after an OK:

    set vfs.unmapped_buf_allowed=0
    boot
    

    Note that the following line has to be added to /boot/loader.conf after a boot. It disables unmapped I/O at every boot:

    vfs.unmapped_buf_allowed=0
    

    Source: https://www.freebsd.org/releases/10.3R/errata.html

    On pfSense you'd do as it says but the line should be added at /boot/loader.conf.local instead of /boot/loader.conf

    Regards,
    Jorge M. Oliveira



  • @JorgeOliveira:

    –---

    On pfSense you'd do as it says but the line should be added at /boot/loader.conf.local instead of /boot/loader.conf

    Regards,
    Jorge M. Oliveira

    Is the code in /boot/loader.conf.local loaded in addition to or instead of /boot/loader.conf?



  • @oletuv:

    Is the code in /boot/loader.conf.local loaded in addition to or instead of /boot/loader.conf?

    In addition.