Problem with Synology NAS external Access router setup



  • I am running pfsense 2.3.1, with private Internet Access VPN service, synology NAS connected to pfsense. I am trying to setup a email server and external access. I cannot get the external access to work. When I run the router set up from within the DiskManager of Synology, I always get an error message saying "two or more routers were found in your network….."

    i am using a cable modem. The modem's DNS server was set to "Manual" without any specific IP put in. The modem then set to a bridge mode by turning off the gateway function.

    The pfsense: PIA DNS servers were used in system/general. DNS resolver disabled. no other DNS server were added to the Interfaces (LAN). In theory, the PIA DNS servers were the only servers available.

    I have tried to bypass the pfsense box by connecting the synology to the cable modem/router, the router set-up was OK for the part no "two or routers were found..."

    Any clue what are the steps of trouble shooting?

    thanks





  • Who is your Internet provider?? Is it business solution or normal home Internet access?? Are you trying by any chance to connect pfSense and Synology to the modem in the same time??

    Looks like you could get this working much quicker by using QuickConnect ID on Synology and leave Synology behind the firewall. Synology however will create/initiate VPN tunnel to Synology servers knocking the hole in your perimeter… I was using this for a while only. I di not like it as I had permanent, foreign VPN bypassing my firewall into my LAN environment...



  • I had a quick look at my Synology. This option related to the router seem to be some sort of the tool that would help you to reconfigure your home router by adding relevant firewall rules. It is only supported by some routers as per Synology Knowledge Base:

    https://www.synology.com/en-global/knowledgebase/DSM/help/DSM/AdminCenter/connection_routerconf

    It require additional setup and UPnP is involved. So this option may not be something you need to use…